Christoph Pleger | 1 Jul 08:59 2010
Picon

Permissions with gdm and consolekit

Hello,

I have been using pam_devperm.so for a long time. pam_devperm.so is a
PAM module that, with my configuration, changes the ownerships and
permissions of some device nodes in /dev when a user logs in on :0, so
that the device nodes belong to that user and get permissions 600.

Now I realized that if gdm is used as display manager and additionally
consolekit is installed, the permissions are set to 600, but then they
are reset to 660.

What does gdm do that causes the permissions to be changed if
consolekit is installed?

Regards
  Christoph
F. Heitkamp | 1 Jul 14:45 2010
Picon
Picon

gtk2 and gtk3 coexisting.

  I have installed both gtk2 and gtk3.  Now applications have been 
giving me the follow errors.

Gtk-ERROR **: GTK+ 3 symbols detected. Using GTK+ 2.x and GTK+ 3 in the 
same process is not supported
aborting...

Also Icons are not loading and displaying.  I am not sure these two 
problems are related.

How do I make the above error go away?  What libraries need to be 
recompiled against gtk3 (for example)?

If this is a FAQ let me know.

Thanks!

Fred
Adam Rigg | 1 Jul 17:45 2010
Picon

Re: Netbook version


----- pogo1 <at> pacific.net.au wrote:
> I have Ubuntu 9.04 installed on my EEEPC, and I'm upgrading to 10.04.
> 
> Reading between the lines, there doesn't seem to be a way to change
> versions apart from a complete reinstallation, but just in case, is there
> a way to change the gnome interface to the netbook version without
> reinstalling Ubuntu?

In short, that may be tricky... You could always upgrade from source, but if it's one of the more economical
models, it might take a good long while to compile GNOME on an eeePC, not to mention all of the dependencies
that you'd have to satisfy. It looks like you're correct in that Ubuntu recommends only upgrading from one
LTS release to another. So, yeah it's a possibility, but not probably not the safest decision.

That said, you could try the upgrade anyway (I never had much luck upgrading that way, so best to consult the
Ubuntu forums on that one). So, should you decide to do that, you can bypass the full GNOME upgrade by
installing a stable lightweight window manager and then uninstalling GNOME (sudo apt-get remove
ubuntu-desktop) before the upgrade to Lucid. IF the upgrade works, you could then install the
ubuntu-netbook package and remove the intermediate wm.

Whatever you do, I'd suggest that you back up everything that you don't want to lose (just in case)--The
broken system possibility that Ubuntu mentions might not be apparent until after the upgrade--even a few
after a couple of weeks. After several painful experiences, I stick with LTS.

Of course, what is it that you want out of upgrading? Just the new netbook "remix" to speed things up a bit? You
might also try installing lighter weight applications until you get to a point when you're ready to
upgrade (e.g., GNOME-Office instead of OpenOffice, Seamonkey instead of Firefox and Thunderbird).
Double check on the Ubuntu site to see how long they officially support the version that you currently use.

Good luck.
(Continue reading)

Pogo | 3 Jul 08:33 2010
Picon

Re: Netbook version

On Fri, 2010-07-02 at 12:00 +0000, AdamRigg wrote:
>In short, that may be tricky...
>Good luck.

Thanks Adam.

Following advice from the Ubuntu netbook forum, I loaded the Netbook
launcher using Synaptic. That got me most of the way there.

I need to make some changes, the top panel is very attractive in the
demo version, but it didn't come across.The window list in the demo is
icons only, on my panel it is the standard bunch of buttons.

It is mostly right though, so I'll keep poking. The whole interface
could use some decent documentation. Even simple things like adding
items to the favourites menu are undocumented (I found a forum item that
described how someone else did it).

Thanks for your advice. If you should come across some doco on the new
netbook interface, please let me know. For example, I'd like to tint the
lovely transparent menu...

Cheers;

Pogo.
William Case | 6 Jul 04:42 2010

Nautilus side panel for only one URI

Hi;

I have no side panel as my default configuration for nautilus.  I would
like to figure out or someone to suggest how to write a launcher command
so that nautilus opens with the side panel set to 'tree' when I use the
launcher to open nautilus as a directory browser without changing my
default setting for other other uses.

--

-- 
Regards Bill
Fedora 13, Gnome 2.30.2
Evo.2.20.2, Emacs 23.2.1
Brad Beer | 6 Jul 16:08 2010
Picon

Pango End of Line Cursor Issue...

I'm using Pango (and Cairo) for a small text editor application. I'm using PangoLayout with PANGO_WRAP_WORD. To make a cursor, I'm inverting the foreground and background colors using attributes for a single character.  This works fine until I reach the end of a line! Then my cursor disappears (I want it to appear after the word so I can add a suffix or something.)

What am I missing?

If this isn't the correct place to ask this, please point me in the correct direction.

Thank you much,

Brad Beer

_______________________________________________
gnome-list mailing list
gnome-list <at> gnome.org
http://mail.gnome.org/mailman/listinfo/gnome-list
William Case | 7 Jul 02:05 2010

How can I stop Epiphany from running the recovery dialogue ??

Hi;

I keep Epiphany's book mark window loaded but as a panel icon. Whenever
I logout with the icon still viable (which is often, I forget about it)
I get an unnecessary recovery dialogue on logging back in. How can I
turn this warning off?

--

-- 
Regards Bill
Fedora 13, Gnome 2.30.2
Evo.2.20.2, Emacs 23.2.1
Kjeld Flarup | 7 Jul 12:43 2010
Picon

Permission denied on .gvfs

Hello

When running backup jobs as root, the .gvfs mount is causing permission
denied warnings from both tar & find jobs.

I find this very annoying.

Is it advisable to unmount .gvfs before running a backup?

Or are there other posibilities to prevent these messages.

--

-- 
-------------------- Med Liberalistiske Hilsner ----------------------
   Civilingeniør, Kjeld Flarup - Mit sind er mere åbent end min tegnebog
   Vinderupvej 12, 7600 Struer, Tlf: 40 29 41 49
   Den ikke akademiske hjemmeside for liberalismen - www.liberalismen.dk
Joseph Bus | 7 Jul 16:48 2010
Picon

Nautilis "Could*not*display*network:///"

Appreciate any ideas on "How To reconfigure Nautilis, networking, FileManagement, or WHATEVER! ..."
to satisfy this diagnostic...Thx, Joseph

_______________________________________________
gnome-list mailing list
gnome-list <at> gnome.org
http://mail.gnome.org/mailman/listinfo/gnome-list
John Jason Jordan | 7 Jul 16:44 2010
Picon
Picon

Re: Permission denied on .gvfs

On Wed, 7 Jul 2010 12:43:30 +0200
"Kjeld Flarup" <kjeld.flarup <at> liberalismen.dk> dijo:

>Hello
>
>When running backup jobs as root, the .gvfs mount is causing permission
>denied warnings from both tar & find jobs.
>
>I find this very annoying.
>
>Is it advisable to unmount .gvfs before running a backup?
>
>Or are there other posibilities to prevent these messages.

I would also like an answer to this question. I use rdiff-backup and it
errors on the .gvfs mount causing the backup to halt. Luckily it gets
to the error message after only a few minutes of the backup, so I can
just wait for it to happen and then tell the backup to continue. I've
tried excluding it from the backup, but so far haven't hit on the right
syntax.

As I recall I tried unmounting it and could not do so, even as root.

I'd like more information on exactly what .gvfs does and who thought it
was a good idea to mess up backups.

Gmane