thelupine | 17 Aug 03:55 2002
Picon
Picon

Re: (no subject) - compiling pango error

On Fri, 2002-08-16 at 16:37, thelupine wrote:
> I'm running a new install of RedHat7.3 with default gnome install.  I'm
> using the latest CVSGNOME, and it dies when it tries to compile pango.
> So, I try it manually, but when I do this:
> ./configure --disable-glibtest --prefix=/usr/local/gnome2/
> make
> 
> I get this:
> /tmp/gnome/pango-1.0.4/pango/querymodules.c:175: undefined reference to
> `pango_config_key_get'
> /tmp/gnome/pango-1.0.4/pango/querymodules.c:177: undefined reference to
> `pango_get_lib_subdirectory'
> /tmp/gnome/pango-1.0.4/pango/querymodules.c:184: undefined reference to
> `pango_split_file_list'
> collect2: ld returned 1 exit status
> make[3]: *** [pango-querymodules] Error 1
> make[3]: Leaving directory `/tmp/gnome/pango-1.0.4/pango'
> make[2]: *** [all-recursive] Error 1
> make[2]: Leaving directory `/tmp/gnome/pango-1.0.4/pango'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/tmp/gnome/pango-1.0.4'
> make: *** [all-recursive-am] Error 2
> 
>   I've exported my path to the include /usr/local/gnome2/bin/ and I've
> updated ld.so.conf to include /usr/local/gnome2/lib/ then ran ldconfig. 
> Am I missing something else?
> 
> If I don't use --disable-glibtest, then I get this:
> checking for GLIB - version >= 2.0.0... 
> *** 'pkg-config --modversion glib-2.0' returned 2.0.6, but GLIB (2.0.1)
(Continue reading)

Owen Taylor | 17 Aug 15:15 2002
Picon

Re: (no subject)


thelupine <thelupine <at> softhome.net> writes:

> I'm running a new install of RedHat7.3 with default gnome install.  I'm
> using the latest CVSGNOME, and it dies when it tries to compile pango.
> So, I try it manually, but when I do this:
> ./configure --disable-glibtest --prefix=/usr/local/gnome2/
> make
> 
> I get this:
> /tmp/gnome/pango-1.0.4/pango/querymodules.c:175: undefined reference to
> `pango_config_key_get'
> /tmp/gnome/pango-1.0.4/pango/querymodules.c:177: undefined reference to
> `pango_get_lib_subdirectory'
> /tmp/gnome/pango-1.0.4/pango/querymodules.c:184: undefined reference to
> `pango_split_file_list'

It didn't find any Pango backends because you, most likely, don't
have the headers for freetype or Xlib installed. I put a fix
into CVS right after 1.0.4 so that configure.in would die
a better error message in this case:

Thu Aug  1 10:41:26 2002  Owen Taylor  <otaylor <at> redhat.com>

        * configure.in: Fix check for having any backend
        HAVE_XFT => have_xft, etc. (Problem reported
        by Andreas J Guelzow)

Regards,
                                        Owen
(Continue reading)

thelupine | 17 Aug 18:21 2002
Picon
Picon

Re: (no subject)

On Sat, 2002-08-17 at 09:15, Owen Taylor wrote:
> 
> thelupine <thelupine <at> softhome.net> writes:
> 
> > I'm running a new install of RedHat7.3 with default gnome install.  I'm
> > using the latest CVSGNOME, and it dies when it tries to compile pango.
> > So, I try it manually, but when I do this:
> > ./configure --disable-glibtest --prefix=/usr/local/gnome2/
> > make
> > 
> > I get this:
> > /tmp/gnome/pango-1.0.4/pango/querymodules.c:175: undefined reference to
> > `pango_config_key_get'
> > /tmp/gnome/pango-1.0.4/pango/querymodules.c:177: undefined reference to
> > `pango_get_lib_subdirectory'
> > /tmp/gnome/pango-1.0.4/pango/querymodules.c:184: undefined reference to
> > `pango_split_file_list'
> 
> It didn't find any Pango backends because you, most likely, don't
> have the headers for freetype or Xlib installed. I put a fix
> into CVS right after 1.0.4 so that configure.in would die
> a better error message in this case:
> 
> Thu Aug  1 10:41:26 2002  Owen Taylor  <otaylor <at> redhat.com>
> 
>         * configure.in: Fix check for having any backend
>         HAVE_XFT => have_xft, etc. (Problem reported
>         by Andreas J Guelzow)
> 
> Regards,
(Continue reading)


Gmane