Shawn Shen | 1 Nov 10:01 2006
Picon

Re: Has anyone built the firefox2 with garnome?

Hi Stef,

Thank you for your reply.
After removing the cookie infor for firefox 1.5.0.6, the installation is ok now.

Thanks a lot.

Regards,
Shawn



On 10/31/06, svdmade <at> planet.nl <svdmade <at> planet.nl> wrote:

Hi Shen,

I built firefox from source with no issues. The garnome compilation of
desktop, fifth-toe and platform wen't OK using this version of firefox.

Cheers,

Stef




Hi All,

The Firefox 2 was released days ago. I tested the binary version, tt looks very good.

I want to build from the source, is there anyone who has ever tried?

Your comments are appreciated!

Thanks,

Regards,
Shawn

--
garnome-list mailing list
garnome-list <at> gnome.org
http://mail.gnome.org/mailman/listinfo/garnome-list



--

-- 
garnome-list mailing list
garnome-list <at> gnome.org
http://mail.gnome.org/mailman/listinfo/garnome-list
Michael Ott | 1 Nov 20:52 2006
Picon

Problems compiling hal

Hi!

My normal system is Debian SID. And I try to compile the latest unstable
gnome using gargnome (2.17.2)

But I got the following messages:
addon-macbookpro-backlight.c:311: warning: initialization from incompatible pointer type
/bin/sh ../../../libtool --tag=CC --mode=link cc  -g -I/home/michael/garnome/include
-L/home/michael/garnome/lib -O2 -pipe -Wall -Wchar-subscripts -Wmissing-declarations
-Wnested-externs -Wpointer-arith -Wcast-align -Wsign-compare  -Wl,--export-dynamic
-L/home/michael/garnome/lib -o hald-addon-macbookpro-backlight  addon-macbookpro-backlight.o
logger.o ../../../libhal/libhal.la -lpci -L/home/michael/garnome/lib -ldbus-glib-1 -ldbus-1 -lglib-2.0
cc -g -I/home/michael/garnome/include -O2 -pipe -Wall -Wchar-subscripts -Wmissing-declarations
-Wnested-externs -Wpointer-arith -Wcast-align -Wsign-compare -Wl,--export-dynamic -o
.libs/hald-addon-macbookpro-backlight addon-macbookpro-backlight.o logger.o 
-L/home/michael/garnome/lib ../../../libhal/.libs/libhal.so -lpci
/home/michael/garnome/lib/libdbus-glib-1.so /home/michael/garnome/lib/libgobject-2.0.so
/home/michael/garnome/lib/libdbus-1.so -lnsl /home/michael/garnome/lib/libglib-2.0.so -lrt
-Wl,--rpath -Wl,/home/michael/garnome/lib
/usr/lib/gcc/i486-linux-gnu/4.1.2/../../../../lib/libpci.a(names.o): In function `pci_load_name_list':
(.text+0x533): undefined reference to `gzopen'
/usr/lib/gcc/i486-linux-gnu/4.1.2/../../../../lib/libpci.a(names.o): In function `pci_load_name_list':
(.text+0x5cd): undefined reference to `gzgets'
/usr/lib/gcc/i486-linux-gnu/4.1.2/../../../../lib/libpci.a(names.o): In function `.L154':
(.text+0x6d3): undefined reference to `gzclose'
/usr/lib/gcc/i486-linux-gnu/4.1.2/../../../../lib/libpci.a(names.o): In function `.L154':
(.text+0x6f8): undefined reference to `gzeof'
/usr/lib/gcc/i486-linux-gnu/4.1.2/../../../../lib/libpci.a(names.o): In function `.L154':
(.text+0x788): undefined reference to `gzclose'
/usr/lib/gcc/i486-linux-gnu/4.1.2/../../../../lib/libpci.a(names.o): In function `.L154':
(.text+0xb9c): undefined reference to `gzopen'
/usr/lib/gcc/i486-linux-gnu/4.1.2/../../../../lib/libpci.a(names.o): In function `.L155':
(.text+0xd33): undefined reference to `gzerror'
/usr/lib/gcc/i486-linux-gnu/4.1.2/../../../../lib/libpci.a(names.o): In function `.L155':
(.text+0xd53): undefined reference to `gzclose'
collect2: ld returned 1 exit status
make[12]: *** [hald-addon-macbookpro-backlight] Error 1
make[12]: Leaving directory `/home/michael/cvs/garnome/freedesktop/hal/work/main.d/hal-0.5.8.1/hald/linux/addons'
make[11]: *** [all-recursive] Error 1
make[11]: Leaving directory `/home/michael/cvs/garnome/freedesktop/hal/work/main.d/hal-0.5.8.1/hald/linux'
make[10]: *** [all-recursive] Error 1
make[10]: Leaving directory `/home/michael/cvs/garnome/freedesktop/hal/work/main.d/hal-0.5.8.1/hald'
make[9]: *** [all] Error 2
make[9]: Leaving directory `/home/michael/cvs/garnome/freedesktop/hal/work/main.d/hal-0.5.8.1/hald'
make[8]: *** [all-recursive] Error 1
make[8]: Leaving directory `/home/michael/cvs/garnome/freedesktop/hal/work/main.d/hal-0.5.8.1'
make[7]: *** [all] Error 2
make[7]: Leaving directory `/home/michael/cvs/garnome/freedesktop/hal/work/main.d/hal-0.5.8.1'
make[6]: *** [build-work/main.d/hal-0.5.8.1/Makefile] Error 2
make[6]: Leaving directory `/home/michael/cvs/garnome/freedesktop/hal'
make[5]: *** [../../freedesktop/hal/cookies/main.d/install] Error 2
make[5]: Leaving directory `/home/michael/cvs/garnome/platform/gnome-vfs'
make[4]: *** [../../platform/gnome-vfs/cookies/main.d/install] Error 2
make[4]: Leaving directory `/home/michael/cvs/garnome/platform/libgnome'
make[3]: *** [../../platform/libgnome/cookies/main.d/install] Error 2
make[3]: Leaving directory `/home/michael/cvs/garnome/platform/libbonoboui'
make[2]: *** [../../platform/libbonoboui/cookies/main.d/install] Error 2
make[2]: Leaving directory `/home/michael/cvs/garnome/platform/libgnomeui'
make[1]: *** [../../platform/libgnomeui/cookies/main.d/install] Error 2
make[1]: Leaving directory `/home/michael/cvs/garnome/desktop/bug-buddy'
make: *** [paranoid-install] Error 2

Which package I forget to install. The messages I found about this error
was missing zlib packages. But I installed the zlib packages:
$ dpkg -l | grep zlib
ii  libcompress-zlib-perl            1.42-1                          Perl module for creation and manipulation of gzip files
ii  zlib1g                           1.2.3-13                        compression library - runtime
ii  zlib1g-dev

Can anybody help me. At work I can compile it (using Debian testing)

Thanks in advance

CU        

  Michael  

-- 
    ,''`.   Michael Ott, e-mail: michael at king-coder dot de
   : :' :   Debian SID on Thinkpad T43: 
   `. `'    http://www.zolnott.de/laptop/ibm-t43-uc34nge.html 
     `-
--

-- 
garnome-list mailing list
garnome-list <at> gnome.org
http://mail.gnome.org/mailman/listinfo/garnome-list
Michael Ott | 2 Nov 00:33 2006
Picon

Re: Problems compiling hal

Hi!

> My normal system is Debian SID. And I try to compile the latest unstable
> gnome using gargnome (2.17.2)
> 
> But I got the following messages:
[...]
> (.text+0x533): undefined reference to `gzopen'
> /usr/lib/gcc/i486-linux-gnu/4.1.2/../../../../lib/libpci.a(names.o): In function `pci_load_name_list':

I answer on my own mail. The problem was that the pciutils-dev for SID
does not work correct. Downgrade to testing helped. 

Send message to Debian 

CU        

  Michael  

-- 
    ,''`.   Michael Ott, e-mail: michael at king-coder dot de
   : :' :   Debian SID on Thinkpad T43: 
   `. `'    http://www.zolnott.de/laptop/ibm-t43-uc34nge.html 
     `-
--

-- 
garnome-list mailing list
garnome-list <at> gnome.org
http://mail.gnome.org/mailman/listinfo/garnome-list
Kelsang Tsenle | 2 Nov 11:59 2006
Picon

successfully compiled garnome 2.16.1.1 on Mandriva 2007

Hi all,

with only a few problems I compiled garnome 2.16.1.1 on Mandriva 2007 
Free Edition. In case someone else wants to try, here are all problems I 
encountered and my workarounds.
The system was not freshly installed, but updated from Mandriva 2006. It 
may be that most of the problems were inherited from my fooling around 
with the old version and won't occur on a fresh system.

Ok, here we go:

*freedesktop/glitz didn't configure. It said GL/gl.h and GL/glx.h are 
missing, although they were installed in /usr/X11/include/GL. After 
copying this directory to /opt/garnome-2.16.1.1/include/, it worked.

*desktop/evolution-data-server didn't configure, because it couldn't 
find the OpenLDAP libraries, although they were installed. config.log 
showed that ld didn't find -llber.
In /usr/lib there were several wrong symlinks. Example: 
libaudiofile.so.0 was a correct link to libaudiofile.so.0.0.2, but 
libaudiofile.so was a dead link to an older version. After fixing these 
links, all libraries were found.

*compiling often stopped in several packages because of these dead 
links, until I fixed them all.

*bootstrap/opal didn't compile, because line 66 in 
/usr/include/speex/speex_echo.h, 'float * restrict W;' was not accepted 
by the compiler. I replaced that line with 'float *W;', so it looks like 
the lines below and above (none of them are 'restricted').

*beagle didn't configure and complained about underquoted definitions of 
... (several files), and missing AM_PATH_ORBIT2. That was fixed by 
installing autoconf and automake from bootstrap.

Hope that helps someone.

Now everything is running fine, except Gimmie. It's not part of Garnome, 
but just in case, did anyone successfully started that with Mandriva?

Gratefully,
 Tsenle
--

-- 
garnome-list mailing list
garnome-list <at> gnome.org
http://mail.gnome.org/mailman/listinfo/garnome-list

Markus Eich | 6 Nov 13:40 2006
Picon
Picon

office/present build error with garnome 2-16

Dear Joseph,

again I am facing a build error with GARNOME-2.16. The error happened in
office/present:

checking for PRESENT... configure: error: Package requirements (
libgoffice-1 >= 0.0.2
) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the PRESENT_CFLAGS and PRESENT_LIBS
environment variables
to avoid the need to call pkg-config. See the pkg-config man page for
more details.
make: *** [configure-work/main.d/present-0.0.3/configure] Fehler 1

Although libgofffice is installed and it's linked to
/usr/local/lib/pkgconfig (I installed it from source).

directory of pkgconfig:

13:35 eich-lap:../office/present > cd /usr/local/lib/pkgconfig/
13:38 eich-lap:../lib/pkgconfig > ls
. cairo-xlib.pc gstreamer-0.10.pc
.. cairo-xlib-xrender.pc gstreamer-base-0.10.pc
cairo-ft.pc glib-2.0.pc gstreamer-controller-0.10.pc
cairo.pc glibmm-2.4.pc gstreamer-dataprotocol-0.10.pc
cairo-pdf.pc gmodule-2.0.pc gstreamer-net-0.10.pc
cairo-png.pc gmodule-export-2.0.pc gthread-2.0.pc
cairo-ps.pc gmodule-no-export-2.0.pc libgoffice-0.3.pc
cairo-svg.pc gobject-2.0.pc theora.pc

How can i convince make that I do have libgoffice installed. Tried
ldconfig but it did not help

Thnx

/Markus

-- 
Dipl. Inform. Markus Eich
Research Assistant
Robotics Lab at
DFKI Bremen
German Research Center for Artificial Intelligence

Email:  markus.eich <at> dfki.de
Tel.:   +49 (421) 218-64105
Fax :   +49 (421) 218-64150
Room:   212

Postal address:
DFKI Bremen
Robotics Lab
Markus Eich
Robert-Hooke-Strasse 5
28359 Bremen
Germany

Further informations:
http://www.dfki.de/robotics

--

-- 
garnome-list mailing list
garnome-list <at> gnome.org
http://mail.gnome.org/mailman/listinfo/garnome-list

Joseph E. Sacco, Ph.D. | 6 Nov 14:27 2006
Picon
Picon

Re: office/present build error with garnome 2-16

Markus,

office/present is broken. If you hack your way around the libgoffice
issue, office/present is still broken.  I have been bugging the author
to fix it.

-Joseph

==========================================================================

On Mon, 2006-11-06 at 13:40 +0100, Markus Eich wrote:
> Dear Joseph,
> 
> again I am facing a build error with GARNOME-2.16. The error happened in
> office/present:
> 
> checking for PRESENT... configure: error: Package requirements (
> libgoffice-1 >= 0.0.2
> ) were not met.
> Consider adjusting the PKG_CONFIG_PATH environment variable if you
> installed software in a non-standard prefix.
> 
> Alternatively you may set the PRESENT_CFLAGS and PRESENT_LIBS
> environment variables
> to avoid the need to call pkg-config. See the pkg-config man page for
> more details.
> make: *** [configure-work/main.d/present-0.0.3/configure] Fehler 1
> 
> Although libgofffice is installed and it's linked to
> /usr/local/lib/pkgconfig (I installed it from source).
> 
> directory of pkgconfig:
> 
> 13:35 eich-lap:../office/present > cd /usr/local/lib/pkgconfig/
> 13:38 eich-lap:../lib/pkgconfig > ls
> . cairo-xlib.pc gstreamer-0.10.pc
> .. cairo-xlib-xrender.pc gstreamer-base-0.10.pc
> cairo-ft.pc glib-2.0.pc gstreamer-controller-0.10.pc
> cairo.pc glibmm-2.4.pc gstreamer-dataprotocol-0.10.pc
> cairo-pdf.pc gmodule-2.0.pc gstreamer-net-0.10.pc
> cairo-png.pc gmodule-export-2.0.pc gthread-2.0.pc
> cairo-ps.pc gmodule-no-export-2.0.pc libgoffice-0.3.pc
> cairo-svg.pc gobject-2.0.pc theora.pc
> 
> How can i convince make that I do have libgoffice installed. Tried
> ldconfig but it did not help
> 
> 
> Thnx
> 
> 
> /Markus
> 
> 
> 
> 
> 
> 
> -- 
> Dipl. Inform. Markus Eich
> Research Assistant
> Robotics Lab at
> DFKI Bremen
> German Research Center for Artificial Intelligence
> 
> Email:  markus.eich <at> dfki.de
> Tel.:   +49 (421) 218-64105
> Fax :   +49 (421) 218-64150
> Room:   212
> 
> Postal address:
> DFKI Bremen
> Robotics Lab
> Markus Eich
> Robert-Hooke-Strasse 5
> 28359 Bremen
> Germany
> 
> Further informations:
> http://www.dfki.de/robotics
> 
-- 
joseph_sacco [at] comcast [dot] net

--

-- 
garnome-list mailing list
garnome-list <at> gnome.org
http://mail.gnome.org/mailman/listinfo/garnome-list

guenther | 9 Nov 02:17 2006
Picon

[ANNOUNCE] GARNOME 2.17.2 -- "miles to go before I sleep"

GARNOME 2.17.2
==============

The "miles to go before I sleep" release.

We are pleased to announce the release of GARNOME 2.17.2 Desktop and
Developer Platform. This release includes all of GNOME 2.17.2 plus a
whole bunch of updates that were released after the GNOME freeze date.

This is the second release in the unstable cycle, with more features,
more fixes and yet more madness added. It is for anyone who wants to get
his hands dirty on the development branch, or who'd like to get a peek
at future features. If you want to help spot issues in GARNOME, (or,
better yet, fix 'em ;-) this release is for you as well.

As usual, you can get the tarball directly from the gnome.org site:
 http://download.gnome.org/sources/garnome/2.17/

Note: GNOME 2.17.x is an unstable branch and is assumed to be a moving
target. Therefore, things in this release may not work as advertised.

If you find any issues with this release, feel free to contact the
GARNOMEies in the #garnome channel on GIMPNet (irc://irc.gnome.org),
where we hang out, or post to the mailing list.

More information is available at our project website:
 http://www.gnome.org/projects/garnome/

Enjoy,

  The GARNOME Team

-- 
char *t="\10pse\0r\0dtu\0. <at> ghno\x4e\xc8\x79\xf4\xab\x51\x8a\x10\xf4\xf4\xc4";
main(){ char h,m=h=*t++,*x=t+2*h,c,i,l=*x,s=0; for (i=0;i<l;i++){ i%8? c<<=1:
(c=*++x); c&128 && (s+=h); if (!(h>>=1)||!t[s+h]){ putchar(t[s]);h=m;s=0; }}}

--

-- 
garnome-list mailing list
garnome-list <at> gnome.org
http://mail.gnome.org/mailman/listinfo/garnome-list

Frank J.R.Hanstick | 12 Nov 11:37 2006
Picon
Picon

Dependency Error

Hello,
	I am trying to install gnome via garnome (2.16.0) on my G4 PPC mac  
(Darwin 8.8.0) and get the following dependency error for ==> Running  
configure in work/main.d/gtk+-2.10.3:

checking for BASE_DEPENDENCIES... configure: error: Package  
requirements (glib-2.0 >= 2.12.0    atk >= 1.9.0    pango >=  
1.12.0    cairo >= 1.2.0) were not met.

	The configure.log file contained the following detailed information:

configure:21250: checking for BASE_DEPENDENCIES
configure:21255: $PKG_CONFIG --exists --print-errors "glib-2.0 >=  
2.12.0    atk >= 1.9.0    pango >= 1.12.0    cairo >= 1.2.0"
Package libpng12 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libpng12.pc'
to the PKG_CONFIG_PATH environment variable
Package 'libpng12', required by 'cairo', not found
configure:21258: $? = 1
configure:21269: $PKG_CONFIG --exists --print-errors "glib-2.0 >=  
2.12.0    atk >= 1.9.0    pango >= 1.12.0    cairo >= 1.2.0"
Package libpng12 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libpng12.pc'
to the PKG_CONFIG_PATH environment variable
Package 'libpng12', required by 'cairo', not found
configure:21272: $? = 1
Package libpng12 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libpng12.pc'
to the PKG_CONFIG_PATH environment variable
Package 'libpng12', required by 'cairo', not found
configure:21293: error: Package requirements (glib-2.0 >= 2.12.0     
atk >= 1.9.0    pango >= 1.12.0    cairo >= 1.2.0) were not met.

	I thought all dependencies were to be taken care of by garnome; but,  
could not find a libpng12 folder anywhere in garnome-2.16.0.  Where  
do I go from here?

	For the record, I tried garnome-2.16.1.1 and get a not found error  
for _FSPathMakeRef in libfreetype.6.dylis.

	One more item.  --Export-dynamic is not a recognized parameter for  
ld in Darwin.  I changed the reference to -dynamic (even though it is  
the default setting) and got as far as the dependency error.

Frank
PS:  I signed up, so I should be on the mailing list.
--

-- 
garnome-list mailing list
garnome-list <at> gnome.org
http://mail.gnome.org/mailman/listinfo/garnome-list

Joseph E. Sacco, Ph.D. | 12 Nov 15:21 2006
Picon
Picon

Re: Dependency Error

Frank,

GARNOME handles dependencies within the GARNOME source tree. It does not
handle *external* dependencies.

What to do...

You are building under OSX. Install Fink

        http://fink.sourceforge.net/

and add whatever external packages you require.

-Joseph

===============================================================
On Sun, 2006-11-12 at 02:37 -0800, Frank J.R.Hanstick wrote:
> Hello,
> 	I am trying to install gnome via garnome (2.16.0) on my G4 PPC mac  
> (Darwin 8.8.0) and get the following dependency error for ==> Running  
> configure in work/main.d/gtk+-2.10.3:
> 
> checking for BASE_DEPENDENCIES... configure: error: Package  
> requirements (glib-2.0 >= 2.12.0    atk >= 1.9.0    pango >=  
> 1.12.0    cairo >= 1.2.0) were not met.
> 
> 	The configure.log file contained the following detailed information:
> 
> configure:21250: checking for BASE_DEPENDENCIES
> configure:21255: $PKG_CONFIG --exists --print-errors "glib-2.0 >=  
> 2.12.0    atk >= 1.9.0    pango >= 1.12.0    cairo >= 1.2.0"
> Package libpng12 was not found in the pkg-config search path.
> Perhaps you should add the directory containing `libpng12.pc'
> to the PKG_CONFIG_PATH environment variable
> Package 'libpng12', required by 'cairo', not found

[snip...]

> 
> 	I thought all dependencies were to be taken care of by garnome; but,  
> could not find a libpng12 folder anywhere in garnome-2.16.0.  Where  
> do I go from here?
> 
> 	For the record, I tried garnome-2.16.1.1 and get a not found error  
> for _FSPathMakeRef in libfreetype.6.dylis.
> 
> 	One more item.  --Export-dynamic is not a recognized parameter for  
> ld in Darwin.  I changed the reference to -dynamic (even though it is  
> the default setting) and got as far as the dependency error.
> 
> Frank
> PS:  I signed up, so I should be on the mailing list.
-- 
joseph_sacco [at] comcast [dot] net

--

-- 
garnome-list mailing list
garnome-list <at> gnome.org
http://mail.gnome.org/mailman/listinfo/garnome-list

svdmade | 12 Nov 18:44 2006
Picon

Dependencies and updated software


Hi Joseph,

Could you please add a dependency for geektoys/gnome-mount building
gnome-mount needs eel and nautilus

Oh and gaim is at beta5 and mono just released version 1.2.

Thanks,

Stef

--

-- 
garnome-list mailing list
garnome-list <at> gnome.org
http://mail.gnome.org/mailman/listinfo/garnome-list


Gmane