edson.caetano | 5 Jan 17:46 2006
Picon

garnome 2.13.3 + Ubunto 5.10

Can anyone help me about the error below, please? 

        [patch] complete for libtool. 
        [fixup] complete for libtool. 
 ==> Running configure in work/main.d/libtool-1.5.20 
checking for a BSD-compatible install... /usr/bin/install -c 
checking whether build environment is sane... yes 
checking for gawk... gawk 
checking whether make sets $(MAKE)... yes 
checking for gcc... cc 
checking for C compiler default output file name... configure: error: C 
compiler cannot create executables 
See `config.log' for more details. 
make[3]: *** [configure-work/main.d/libtool-1.5.20/configure] Error 77 
make[3]: Leaving directory `/home/dsonc/garnome-2.13.3/bootstrap/libtool' 
make[2]: *** [fixuplibtool] Error 2 
make[2]: Leaving directory `/home/dsonc/garnome-2.13.3/platform/libgnomeui' 
make[1]: *** [../../platform/libgnomeui/cookies/main.d/install] Error 2 
make[1]: Leaving directory `/home/dsonc/garnome-2.13.3/desktop/bug-buddy' 
make: *** [paranoid-install] Error 2 

--

-- 
garnome-list mailing list
garnome-list <at> gnome.org
http://mail.gnome.org/mailman/listinfo/garnome-list
guenther | 5 Jan 17:57 2006
Picon

[ANNOUNCE] GARNOME 2.13.4

GARNOME 2.13.4
==============

The "timezones make a difference" release.

We are pleased to announce the release of GARNOME 2.13.4 Desktop and
Developer Platform. This release includes all of GNOME 2.13.4 plus a lot
of tweaked build-magic. It is for anyone who wants to get his hands
dirty on the development branch.

Tarball:
 http://ftp.gnome.org/pub/GNOME/sources/garnome/2.13/garnome-2.13.4.tar.bz2
 MD5: 3d59cacd216fd12e18bee5ad7a6842fe

Note: GNOME 2.13.x is an unstable branch and is assumed to be a moving
target. Therefore, things in this release may not work as advertised. If
you find any issues with this release, then please consider joining the
#garnome channel on GIMPNet (irc://irc.gnome.org) or post to the mailing
list.

Enjoy,

  The GARNOME Team

--

-- 
char *t="\10pse\0r\0dtu\0. <at> ghno\x4e\xc8\x79\xf4\xab\x51\x8a\x10\xf4\xf4\xc4";
main(){ char h,m=h=*t++,*x=t+2*h,c,i,l=*x,s=0; for (i=0;i<l;i++){ i%8? c<<=1:
(c=*++x); c&128 && (s+=h); if (!(h>>=1)||!t[s+h]){ putchar(t[s]);h=m;s=0; }}}
edson.caetano | 5 Jan 18:23 2006
Picon

Re: [ANNOUNCE] GARNOME 2.13.4

I need a help: 

        [patch] complete for libtool. 
        [fixup] complete for libtool. 
 ==> Running configure in work/main.d/libtool-1.5.22 
checking for a BSD-compatible install... /usr/bin/install -c 
checking whether build environment is sane... yes 
checking for gawk... gawk 
checking whether make sets $(MAKE)... yes 
checking for gcc... cc 
checking for C compiler default output file name... configure: error: C 
compiler cannot create executables 
See `config.log' for more details. 
make[3]: *** [configure-work/main.d/libtool-1.5.22/configure] Error 77 
make[3]: Leaving directory `/home/dsonc/garnome-2.13.4/bootstrap/libtool' 
make[2]: *** [fixuplibtool] Error 2 
make[2]: Leaving directory `/home/dsonc/garnome-2.13.4/platform/libgnomeui' 
make[1]: *** [../../platform/libgnomeui/cookies/main.d/install] Error 2 
make[1]: Leaving directory `/home/dsonc/garnome-2.13.4/desktop/bug-buddy' 
make: *** [paranoid-install] Error 2 

This problem occurs with 2.13.3 version too.  Regards. 

Em (17:57:48), guenther escreveu: 

>GARNOME 2.13.4 
>============== 
> 
>The "timezones make a difference" release. 
> 
(Continue reading)

guenther | 5 Jan 19:09 2006
Picon

Re: garnome 2.13.3 + Ubunto 5.10

On Thu, 2006-01-05 at 14:46 -0200, edson.caetano wrote:
> Can anyone help me about the error below, please? 
> 
>         [patch] complete for libtool. 
>         [fixup] complete for libtool. 
>  ==> Running configure in work/main.d/libtool-1.5.20 
> checking for a BSD-compatible install... /usr/bin/install -c 
> checking whether build environment is sane... yes 
> checking for gawk... gawk 
> checking whether make sets $(MAKE)... yes 
> checking for gcc... cc 
> checking for C compiler default output file name... configure: error: C 
> compiler cannot create executables 
> See `config.log' for more details. 

Your C compiler seems to be broken or kind of missing.

FWIW, here is the relevant snippet on my system:

checking whether make sets $(MAKE)... yes
checking for gcc... ccache gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes

Just ignore the 'ccache' bits above. The strange thing is, configure
picks up cc rather than gcc. Did you edit the gar.conf.mk file? What
(Continue reading)

edson.caetano | 5 Jan 19:37 2006
Picon

Re: garnome 2.13.3 + Ubunto 5.10

ok guenther, thanks for help! I got a solution from irc channel, just 
installed build-essentials package and runs fine. As i'm not a developer 
some packages wasn't installed and i run a risk of this kind of errors occur 
again. Once more, thank you! 

Em (19:09:02), guenther escreveu: 

>On Thu, 2006-01-05 at 14:46 -0200, edson.caetano wrote: 
>> Can anyone help me about the error below, please? 
>> 
>> [patch] complete for libtool. 
>> [fixup] complete for libtool. 
>> ==> Running configure in work/main.d/libtool-1.5.20 
>> checking for a BSD-compatible install... /usr/bin/install -c 
>> checking whether build environment is sane... yes 
>> checking for gawk... gawk 
>> checking whether make sets $(MAKE)... yes 
>> checking for gcc... cc 
>> checking for C compiler default output file name... configure: error: C 
>> compiler cannot create executables 
>> See `config.log' for more details. 
> 
>Your C compiler seems to be broken or kind of missing. 
> 
>FWIW, here is the relevant snippet on my system: 
> 
>checking whether make sets $(MAKE)... yes 
>checking for gcc... ccache gcc 
>checking for C compiler default output file name... a.out 
>checking whether the C compiler works... yes 
(Continue reading)

edson.caetano | 5 Jan 21:06 2006
Picon

Re: garnome 2.13.4 + Ubunto 5.10

All was going on well when... i got another error :-/ 

cairosimple.c:82: warning: implicit declaration of function 
‘cairo_surface_write_to_png’ 

Thanks 

Em (19:09:02), guenther escreveu: 

>On Thu, 2006-01-05 at 14:46 -0200, edson.caetano wrote: 
>> Can anyone help me about the error below, please? 
>> 
>> [patch] complete for libtool. 
>> [fixup] complete for libtool. 
>> ==> Running configure in work/main.d/libtool-1.5.20 
>> checking for a BSD-compatible install... /usr/bin/install -c 
>> checking whether build environment is sane... yes 
>> checking for gawk... gawk 
>> checking whether make sets $(MAKE)... yes 
>> checking for gcc... cc 
>> checking for C compiler default output file name... configure: error: C 
>> compiler cannot create executables 
>> See `config.log' for more details. 
> 
>Your C compiler seems to be broken or kind of missing. 
> 
>FWIW, here is the relevant snippet on my system: 
> 
>checking whether make sets $(MAKE)... yes 
>checking for gcc... ccache gcc 
(Continue reading)

Myles Green | 5 Jan 22:54 2006
Picon

Re: garnome 2.13.4 + Ubunto 5.10

On Thu, 5 Jan 2006 18:06:34 -0200
edson.caetano <edson.caetano <at> ig.com.br> wrote:

> All was going on well when... i got another error :-/ 
> 
> cairosimple.c:82: warning: implicit declaration of function 
> ‘cairo_surface_write_to_png’ 
> 
> Thanks 

That's just a warning, did your build stop? Warnings are usually nothing
to worry about. If your build did stop you'll need to include a few
more lines than just that one if you're looking to be of any help to the
developers.

-- 
May you have many beautiful and obedient daughters.
--

-- 
garnome-list mailing list
garnome-list <at> gnome.org
http://mail.gnome.org/mailman/listinfo/garnome-list

Adam Worrall | 5 Jan 23:06 2006
Picon

2.13.3.4, glib 2.9.1, invalid for 'mov'

FWIW, 2.13.3.4 still gives the errors below. I think that's because my
binutils don't like linking against glib 2.9.1. I shall await glib
2.9.2 with excitement !

 - Adam

---------- Forwarded message ----------
From: Adam Worrall <abworrall <at> gmail.com>
Date: Dec 16, 2005 5:37 PM
Subject: gstreamer probs in 2.13.3
To: garnome-list <at> gnome.org

I'm on fc3/x86_64. The build was going swimmingly until I hit
gstreamer. I don't think it is a problem with gstreamer itself, since
the same version (0.8.11) builds fine within Garnome 2.12.2.1.

After googling a little, people seem to be pointing at binutils. I
installed a newer binutils (2.15.92.0.2-5.1), but that didn't do a
lot. There is a newer one for my platform (2.15.94.0.2.2), but the RPM
demands a gcc upgrade I can't do.

Anyone else come across this ?

 cc -DHAVE_CONFIG_H -I. -I. -I.. -I/ita/gar65/include -D_GNU_SOURCE
-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -pthread
-I/ita/gar65/include/glib-2.0 -I/ita/gar65/lib/glib-2.0/include
-I/ita/gar65/include/libxml2 -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -fno-common -g -Wall -DGST_DISABLE_DEPRECATED
-I.. -DGST_MAJORMINOR=\"0.8\" -g -I/ita/gar65/include -L/ita/gar65/lib
-O2 -pipe -g -I/ita/gar65/include -L/ita/gar65/lib -O2 -pipe -g
(Continue reading)

Bob Kashani | 6 Jan 06:56 2006
Picon

Re: 2.13.3.4, glib 2.9.1, invalid for 'mov'

On Thu, 2006-01-05 at 17:06 -0500, Adam Worrall wrote:
> FWIW, 2.13.3.4 still gives the errors below. I think that's because my
> binutils don't like linking against glib 2.9.1. I shall await glib
> 2.9.2 with excitement !

Adam, glib 2.9.2 was just released. Give it a shot and report back. :)

Bob

-- 
Bob Kashani
http://www.gnome.org/projects/garnome
http://www.ocf.berkeley.edu/~bobk/garnome

--

-- 
garnome-list mailing list
garnome-list <at> gnome.org
http://mail.gnome.org/mailman/listinfo/garnome-list

edson.caetano | 6 Jan 11:24 2006
Picon

Re: garnome 2.13.4 + Ubunto 5.10

yes the build stopped, some more details : 

make[11]: Entering directory 
`/home/dsonc/garnome-2.13.4/platform/pango/work/main.d/pango-1.11.1/examples' 
/bin/sh ../libtool --mode=link cc  -g -I/home/dsonc/garnome/include 
-L/home/dsonc/garnome/lib -O2 -pipe -Wall  -Wl,--export-dynamic 
-L/home/dsonc/garnome/lib -o cairosimple  cairosimple.o 
../pango/libpango-1.0.la ../pango/libpangocairo-1.0.la 
-L/home/dsonc/garnome/lib -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0   
-L/home/dsonc/garnome/lib -lcairo 
cc -g -I/home/dsonc/garnome/include -O2 -pipe -Wall -Wl,--export-dynamic -o 
.libs/cairosimple cairosimple.o  -L/home/dsonc/garnome/lib 
../pango/.libs/libpango-1.0.so ../pango/.libs/libpangocairo-1.0.so 
-L/usr/X11R6/lib

/home/dsonc/garnome-2.13.4/platform/pango/work/main.d/pango-1.11.1/pango/.libs/libpangoft2-1.0.so

/home/dsonc/garnome-2.13.4/platform/pango/work/main.d/pango-1.11.1/pango/.libs/libpango-1.0.so 
/home/dsonc/garnome/lib/libgobject-2.0.so 
/home/dsonc/garnome/lib/libgmodule-2.0.so 
/home/dsonc/garnome/lib/libglib-2.0.so /home/dsonc/garnome/lib/libcairo.so 
/home/dsonc/garnome/lib/libXrender.so -lX11 
/home/dsonc/garnome/lib/libfontconfig.so /home/dsonc/garnome/lib/libxml2.so 
-ldl /home/dsonc/garnome/lib/libfreetype.so -lz -lm -Wl,--rpath 
-Wl,/home/dsonc/garnome/lib 
cairosimple.o: In function `main':

/home/dsonc/garnome-2.13.4/platform/pango/work/main.d/pango-1.11.1/examples/cairosimple.c:82: 
undefined reference to `cairo_surface_write_to_png' 
collect2: ld returned 1 exit status 
(Continue reading)


Gmane