Arthur Lambert | 4 Mar 15:44 2014

[GLIB] memory leak in glib 2.32.4 ?

Hi All,

I am using glib with GValue, GPtrArray to communicate with dbus. I
have a big memory leak in my code. I am running an embedded target
with glib 2.32.4. I am currently trying to  code some little binary to
detect the leak. I am not the author of the code so it is quite hard
for me to debug it.

So I have currently for example a little main which does not leak at
all on a desktop linux version (Fedora 17) which use the same glib
version( perhaps not exactly the same verson but major, minor and
macro number version seems to be the same. But when I run this piece
of code on my embedded linux, I have a leak of 4 Bytes per loop

Code is :

static void data_constructor_array_struct_string_array_struct_string_variant(GPtrArray
*data, const gchar *client_objname)
  guint member_count;
  GValueArray *outer_struct = g_value_array_new(1);
  GPtrArray *inner_array = g_ptr_array_new ();

  printf ("client objname : %s\n", client_objname);

  g_value_array_append(outer_struct, NULL);
(Continue reading)

Bruce Perens | 25 Feb 06:35 2014

tablet touchscreen configuration

Hi folks,

Is there a mailing list for tablet issues or tablet developers? I didn't see one. Indeed the mailing lists that aren't for developers seem to be for specific applications rather than the system itself. So, please forgive me if this is misplaced.

I've set up Gnome 3 from Debian unstable on a Panasonic Toughpad FZ-G1. This has two sensor surfaces on the screen: a stylus that is or emulates a Wacom, and an eGalaxy Touch which is a multitouch finger touchscreen. Both are using evdev, the eGalaxy also has mtdev. Kernel is 3.14 .

If anyone has tested this device with Gnome or indeed Linux, there isn't any web evidence. It works, with a few little issues that I am now running down.

The Wacom works correctly. The eGalaxy Touch mostly works, but something is different about the button events. On the screen keyboard, the buttons highlight when I touch them but they don't act as if they've been pressed. This also happens on all of the shell panel buttons. But finger-touch on a dock icon correctly launches the program.

In xev, button press and release events look identical between the two devices.

Nice to see that Gnome 3 is mostly usable on tablets. I can probably test multitouch when I get through this issue.



(Continue reading)

Stefan Sauer | 19 Feb 10:13 2014

small incompatible change in gtk-doc 1.20 wrt |[]| markdown


we discovered that change c4d09c7c95c45a1226e83f5ddd7d0f4ce2b1a1a9 which
has been release as part of gtk-doc 1.20 causes a regression for a use
that worked so far. The |[ ... ]| syntax is a shortcut for
<informalexample><programlisting> ...
</programlisting></informalexample>. Now this is automatically wrapped
as CDATA which is convenient as one does not need to use entities for
e.g. &. Unfortunately that breaks cases where one uses xi:inlcude to
embed the actual example. We fixed all the cases that we found in
modules part of the jhbuild gnome module set. The fix is easy, just
replace the |[ ]| with the docbook tags for now. For a example see

Sorry for any inconvenience,

Cruceru Calin | 17 Feb 10:17 2014

Starting contributing - some questions

Hello everyone,

I'm a first year computer-science romanian student and I would like to start contributing to Gnome.

Firstly, I have to say that I haven't decided yet upon a project on which to contribute, that is why I'm writing to this mailing-list since I expect to get more general advice here.

As far as my knowledgement is concerned, I am well-versed in C and C++, bash scripting and I'm a beginner in javascript. I'm also very passionate about Linux and Gnome in particular. Taking in consideration this, I want you to suggest me a couple of projects which have as requirements these programming languages and where I can find easy bugs to fix for the beginning.

I already read the wiki pages and installed the needed development tools. In fact, right now the jhbuild script is running and it seems promising.

I have one more explicit question to end with: is there a method to import all project's sources in an IDE ( anjuta I guess is most used ) ? I mean in one step or somehow and have it organized in the project within the IDE as they are in the project's directory.

Thank you and I'm looking forward for your support !

Cruceru Calin-Cristian
gnome-devel-list mailing list
gnome-devel-list <at>
Tae Wong | 4 Dec 11:41 2013

GNOME site loading slow

Note that this is the mailing list for GNOME development; it's not
better to report problems with GNOME infrastructure.

When trying to load you'll get an error message saying that
the site can't be displayed.
Dylan McCall | 25 Aug 18:53 2013

Detect when the user logs out, and save state?

I'm working on a small program that sits in the background and runs
several counters and timers:

When the user logs out, I want my application to save its current
state to a file, and then restore from that file when the user logs
back in. Most of this is implemented (with Vala), and I'm connecting
to the SIGINT, SIGTERM and SIGHUP signals to trigger a clean exit:

public int main(string[] args) {
    application = new HelperApplication();
    Posix.signal(Posix.SIGINT, sigint_cb);
    Posix.signal(Posix.SIGTERM, sigint_cb);
    Posix.signal(Posix.SIGHUP, sigint_cb);
    int status =;
    return status;

void sigint_cb(int signal_number) {

(There is a bunch of code in application.quit that handles the state
saving stuff).

Everything is fine if I exit the program by sending it one of those
signals, of course. The problem I'm running into is gnome-session
seems to be more aggressive (is it sending SIGKILL?), so, when the
user logs out, my program doesn't get a chance to save its state.
(Continue reading)

Robin Stocker | 12 Jul 18:54 2013

Experience from writing a tiny GNOME app in Gjs

Hey hey,

I wrote a tiny app in Gjs yesterday and wanted to share my experience.
It's a wrapper around the Spotify web player to add support for media
keys (play/pause, next, previous). It uses Gtk, WebKitGTK+ 2, and DBus.

I started with the gnome-devel-demos [1], which gives a very nice
introduction. The hello world was running quickly and the edit/run cycle
is of course very fast due to not needing compilation.

For adding media key support, I looked at what totem does [2], and tried
to reproduce it. This is where I hit the first road block, there's no
API reference for JS on But I think this should be
addressed with bug 693378. Through searching I found some documentation
which helped [4] (although some things didn't work as documented).

For the WebKitGTK+ API, I looked at the C API reference and puzzled it
out. This was also kind of hard, but it's the same problem as above.

For making it easy to install this, I experimented with a .desktop file
which references the .js and icon through relative paths, but had no
success. I resorted to having an that expands the paths and
copies the file to ~/.local/share/applications/. I'm eagerly awaiting
the "app bundles" work, which should improve the situation [5].

All in all, I think the GNOME platform is moving in the right direction
and there's potential in having a good app development story.

Finally, here's the link to the source, if anyone is interested:
(Continue reading)

Joe Steeve | 8 Jul 22:43 2013

3.10: Non-existant sysdeps in Debian Wheezy

Hello all,

I am trying to build evolution on Debian Wheezy using 3.10 module sets.
This wont build because there are some sysdeps that do not exist (or
version mismatch) on Debian Wheezy.

I mucked around the modulesets to get it to build. I had to add 'gypsy'
alone to the skip list because it has some deprecated gtk+ usage which
is FTBFS. My change are attached to:

Can someone have a look? Thanks.


Joe Steeve
HiPro IT Solutions Private Limited
gnome-love mailing list
gnome-love <at>
Tae Wong | 5 Jul 15:46 2013

GNOME Foundation: the former members!

Gergo Érdi has worked for gnomoku, radio-active, gnome-*, gnome-libs,
gnome-core, bonobo and panel-*. He lives in Singapore and his name
should have a double acute under o in the first name (be careful, some
of the blog posts have spam comments)!

Jaka Močnik has worked for gnome-libs, ghex and ggv (he has
contributed to ghex, ggv and godo). He lives in Slovenia.

The asterisk “*” is a known wildcard.
gnome-devel-list mailing list
gnome-devel-list <at>
Daniel J Blueman | 26 Jun 09:40 2013

GNOME terminal resizing when focus lost

There's a pretty serious usability issue with GNOME terminal 3.6.1
that bites when sloppy focus is enabled.

When there are two of more tabs open and the window is resized, the
window size reverts when focus is lost.

The workaround I've been using is to select a different terminal tab,
then reset the previous one.

Searching yields nothing; if you guys haven't come
across it, what data is useful for me to log it?

Daniel J Blueman
Emmanuele Bassi | 23 May 11:43 2013

Re: json-glib problem


On 23 May 2013 10:14, Aldrich Niklaus <aldrichnjit <at>> wrote:
> after I entering bt,the gdb says "no stack"
> if I run ./all ,I receive the message as follows,
> Starting program: /home/fenghelong/open-source/RenrenSDK/json/all
> [Thread debugging using libthread_db enabled]
> Using host libthread_db library "/lib/x86_64-linux-gnu/".
> Program received signal SIGSEGV, Segmentation fault.
> 0x00007ffff6dbacba in _IO_vfprintf_internal (s=0x7fffffffdf70,
>     format=0x400cfa "error is %s\n", ap=0x7fffffffe0e8) at vfprintf.c:1623

you forgot to initialize GError here:

>> >         GError *error;

you should set it to NULL:

  GError *error = NULL;

before passing it to json_parser_load_from_file();


(Continue reading)