Mariano Suárez-Alvarez | 1 Dec 05:22 2004
Picon

ANNOUNCE: GNOME Terminal 2.9.2

Application
===========

GNOME Terminal 2.9.2

Description
===========

Standard GNOME terminal application.

Enhancements
============

- Correct handling of the clipboard and of the clipboard availability 
  checking.
- Port to the new GTK widgets.
- Support _NET_WM_USER_TIME (Elijah Newren)
- Be HIGgy in a couple of dialogs (Dennis Cranston)
- Translation updates: Vladimir Petkov (bg), Miloslav Trmac (cs), Martin 
  Willemoes Hansen (da), Hendrik Richter (de), Adam Weinberger (en_CA), 
  David Lodge (en_GB), es <at> li.org (es), Laszlo Dvornik (hu), Takeshi 
  AIHANA (ja), Daniel van Eeden (nl), Gustavo Noronha Silva (pt_BR), 
  Laurent Dhima (sq), Funda Wang (zh_CN).

Download
========

http://ftp.gnome.org/pub/GNOME/sources/gnome-terminal/2.9/

Enjoy,
(Continue reading)

Bryce Harrington | 1 Dec 08:04 2004

www.inkscape.org

Inkscape 0.40
=============

Draw Freely.

http://www.inkscape.org/

The Inkscape community is proud to announce release 0.40 of Inkscape, "A
Cross-Platform Open Source Vector Graphics (SVG) Drawing Tool." This
release includes three highly requested new capabilities: Layers,
Text-on-Path, and Bitmap tracing. In addition, several minor features
have made the cut along with a number of usability enhancements, three
new tutorials, and hundreds of bug fixes; this is by far the most
feature-packed release to date!

The implementation of layers provides another means for organization of
compositions. Layers can be locked to not allow changes and their
visibility may be toggled on and off. This is great for sketching over a
bitmap image by using it as a template. However, one might skip this
technique altogether by using the new "Bitmap Tracing" which uses
Potrace to convert pixels/bitmaps into vector graphics. Normally this
function is not found in illustration programs, but now it is front and
center right on the canvas within Inkscape.

Since our last release four months ago, we have added several new
dependencies such as the Boehm garbage collector and the stable Gtk 2.4
libraries. Hence, installing Inkscape on some platforms might raise more
issues than as with previous releases, and we ask you to please post to
the bugtracker (http://inkscape.org/report_bugs.php) any issues
discovered. To help those who run into undocumented problems we're also
(Continue reading)

Callum McKenzie | 2 Dec 07:35 2004
Picon

gnome-games 2.8.2

gnome-games 2.8.2
=================

This is the third stable release of gnome-games in the 2.8
series. There are no new feature, only bug fixes and translation
updates. Unless you are experiencing problems there is no need to
upgrade. Any problems this release does not solve for you should be
reported in the GNOME bugzilla (http://bugzilla.gnome.org/).

There is no corresponding update for gnome-games-extra-data, the 2.8.0
release is still sufficient and can be found at:

 http://ftp.gnome.org/pub/GNOME/sources/gnome-games-extra-data/2.8/

Bugs fixed:
Aisleriot:
 - Fix the end of game check for Odessa.

Ataxx:
 - Fix a crasher on 64-bit machines.

Five or More:
 - Handle missing themes better.

Gnometris:
 - Fix drag and drop from konqueror.
 - Use the ESD compielr flags properly.

libgames-support:
 - Display ace-high card decks properly.
(Continue reading)

Jens Finke | 2 Dec 08:31 2004
Picon

Eye of Gnome 2.8.2 bugfix release

Hi,

recently a lot of crashes have been reported for Eye of Gnome into bugzilla.
James Henstridge was so kind to fix some of these issues. If you noticed 
frequently crashes with Eye of Gnome please try out this release and see if it 
works for you. Please report your success or failure story to bugzilla then. Thanks.

What is it?
------------
Eye of Gnome is the GNOME image viewer, which can read the most commmon image 
formats. You can flip, rotate and convert your images and use the fullscreen 
slideshow component to present your family photos. If libexif is available on 
your system Eye of Gnome will display all the metainformation of your digital 
photos (aka EXIF data).

Where to get it?
----------------
http://ftp.gnome.org/pub/GNOME/sources/eog/2.8/eog-2.8.2.tar.bz2

Whats new?
----------
- Eel dependency removed (Paolo Borelli)
- Important crash fixes (James Henstridge, Jens Finke)
- AIX compilation fixes (Sandie Vanderme)
- Translation Updates:
   Alexander Shopov (bg), David Lodge (en_GB), Dwayne Bailey
   (zu, nso), Martin Willemoes Hansen (da), Mohammad DAMT (id)

Regards,

(Continue reading)

Matthias Clasen | 2 Dec 22:08 2004
Picon

GLib 2.4.8 released

GLib 2.4.8 is now available for download at:

 ftp://ftp.gtk.org/pub/gtk/v2.4/

glib-2.4.8.tar.bz2   md5sum: e160a5feecf46e0fbb36db09c356953c
glib-2.4.8.tar.gz    md5sum: 9e2189e0e2b6d5a869b6410321d4d837

This is a bug fix release and is source and binary compatible
with 2.4.0. 

What is GLib 
============

GLib is the low-level core library that forms the basis for projects
such as GTK+ and GNOME. It provides data structure handling for C,
portability wrappers, and interfaces for such runtime functionality as
an event loop, threads, dynamic loading, and an object system.

More information about GLib is available at:

 http://www.gtk.org/

An installation guide for the GTK+ libraries, including GLib, can
be found at:

 http://developer.gnome.org/doc/API/2.0/gtk/gtk-building.html

Overview of Changes from GLib 2.4.7 to GLib 2.4.8
=================================================
* Reduce signal connection complexity from O(n) to O(1) 
(Continue reading)

Matthias Clasen | 2 Dec 22:22 2004
Picon

GLib 2.5.7 released [unstable]

GLib 2.5.7 is now available for download at:

   ftp://ftp.gtk.org/pub/gtk/v2.5/

glib-2.5.7.tar.gz	md5sum: 730a3980ad9058d8ed9612eccc617d9b
glib-2.5.7.tar.bz2	md5sum: 563aeefa2680d02c68f4e350b8b11092

This is the 8th development release leading up to GLib 2.6.  

Notes:

 * This is unstable development release. While it has had
   fairly extensive testing, there are certainly plenty of 
   bugs remaining to be found. This release should not be 
   used in production.

 * Installing this version will overwrite your existing
   copy of GLib 2.4. If you have problems, you'll need
   to reinstall GLib 2.4.7.

 * GLib 2.6 will be source and binary compatible with
   the GLib 2.4.x series. The new API additions in GLib 
   2.5.x are finalized at this point, and GLib 2.5.x 
   should be considered API frozen. Unless serious issues
   with the new APIs come up, there will be no API 
   changes between this release and the 2.6.0 release.

 * Bugs should be reported to http://bugzilla.gnome.org

About GLib
(Continue reading)

Owen Taylor | 2 Dec 22:37 2004
Picon

Pango-1.7.0 released [unstable]

Pango-1.7.0 is now available for download at:

 ftp://ftp.gtk.org/pub/gtk/v2.5/

pango-1.7.0.tar.bz2   md5sum: 8659fc52457a86f57878c5018140744a
pango-1.7.0.tar.gz    md5sum: c82e6099c49e24b28a30296e36757000

This is a development release leading up to Pango-1.8.0, which 
will be released together with GTK+-2.8.

The major change in this release is PangoRenderer, a base object
holding the logic for rendering PangoLayout which was previously
duplicated in many places. Also in this release, support has
been added for the Lao and Syriac scripts.

Notes:

 * This is unstable development release. While it has had
   fairly extensive testing, there are likely bugs
   remaining to be found. This release should not be used
   in production.

 * Installing this version will overwrite your existing
   copy of Pango-1.6. If you have problems, you'll need
   to reinstall Pango-1.6.0

 * Bugs should be reported to http://bugzilla.gnome.org.

About Pango
===========
(Continue reading)

Owen Taylor | 2 Dec 22:37 2004
Picon

Pango-1.7.0 released [unstable]

Pango-1.7.0 is now available for download at:

 ftp://ftp.gtk.org/pub/gtk/v2.5/

pango-1.7.0.tar.bz2   md5sum: 8659fc52457a86f57878c5018140744a
pango-1.7.0.tar.gz    md5sum: c82e6099c49e24b28a30296e36757000

This is a development release leading up to Pango-1.8.0, which 
will be released together with GTK+-2.8.

The major change in this release is PangoRenderer, a base object
holding the logic for rendering PangoLayout which was previously
duplicated in many places. Also in this release, support has
been added for the Lao and Syriac scripts.

Notes:

 * This is unstable development release. While it has had
   fairly extensive testing, there are likely bugs
   remaining to be found. This release should not be used
   in production.

 * Installing this version will overwrite your existing
   copy of Pango-1.6. If you have problems, you'll need
   to reinstall Pango-1.6.0

 * Bugs should be reported to http://bugzilla.gnome.org.

About Pango
===========
(Continue reading)

Matthias Clasen | 3 Dec 07:00 2004
Picon

GTK+ 2.4.14 released

GTK+ 2.4.14 is now available for download at:

 ftp://ftp.gtk.org/pub/gtk/v2.4/
 http://ftp.gnome.org/pub/GNOME/sources/gtk+/2.4/

gtk+-2.4.14.tar.bz2   md5sum: 10470d574933460809e4ac488e579e26 
gtk+-2.4.14.tar.gz    md5sum: 83f08e51bb7d3caa7e382f1f669c1547

This is a bug fix release and is source and binary compatible
with 2.4.0. 

What is GTK+
============

GTK+ is a multi-platform toolkit for creating graphical user
interfaces. Offering a complete set of widgets, GTK+ is suitable for
projects ranging from small one-off tools to complete application
suites.

GTK+ has been designed from the ground up to support a range of
languages, not only C/C++. Using GTK+ from languages such as Perl and
Python (especially in combination with the Glade GUI builder) provides
an effective method of rapid application development.

GTK+ is free software and part of the GNU Project. However, the
licensing terms for GTK+, the GNU LGPL, allow it to be used by all
pdevelopers, including those developing proprietary software, without
any license fees or royalties.

Where to get more information about GTK+
(Continue reading)

Matthias Clasen | 3 Dec 07:54 2004
Picon

GTK+ 2.5.6 released [unstable]

GTK+ 2.5.6 is now available for download at:

   ftp://ftp.gtk.org/pub/gtk/v2.5/

gtk+-2.5.6.tar.gz       md5sum: 846c148f8c021e06aeb92e28a96e85f2
gtk+-2.5.6.tar.bz2      md5sum: 38e829970c1629ff19b15cae83f42425

This is the 7th development release leading up to GTK+ 2.6.

Notes:

 * This is unstable development release. There are certainly
   plenty of bugs remaining to be found. This release should
   not be used in production.

 * Installing this version will overwrite your existing
   copy of GTK+ 2.4. If you have problems, you'll need
   to reinstall GTK+ 2.4.14.

 * GTK+ 2.6 will be source and binary compatible with
   the GTK+ 2.4.x series; however, the new API additions
   in GTK+ 2.5.6 are not yet completely finalized, so there 
   may be incompatibilities between this release and the final
   2.6 release.

 * GTK+ is in a slush API freeze. There are still a few open
   API issues, but it is very likely that most of them will be
   punted to 2.8. Remaining API issues for GTK+ 2.6 can be
   found with following Bugzilla query:

(Continue reading)


Gmane