Xiang, Haihao | 1 Feb 01:27 2012
Picon

Re: VAAPI (master or ext) no deinterlacing with Clarkdale GPU

Hi, 

   I know what is the problem. For some reason, the native pixel format
for MPEG-2 decoding on Clarkdale is I420, however the input pixel format
of deinterlacing is NV12 in the driver, so the driver doesn't support
deinterlacing for MPEG-2 on Clardale. We will try to fix this issue but
don't expect it too soon.

BTW you can send all VAAPI related mail to libva <at> lists.freedesktop.org
as well.

Thanks
Haihao

> Atechsystem <Atechsystem <at> freenet.de> writes:
> 
> > 
> > 
> > Hello,
> >  
> > I’ve written an email to Haihao Xiang regarding the “no deinterlacing” bug on
> Clarkdale a week ago and he answered today. He will check this issue. I’ll hope
> he can fix it. Will the extended vaapi-ext deinterlacers (temporal or spatial I
> guess) also be available on Clarkdale platform? I tried the extended DXVA
> hardware deinterlacing on Windows today and it worked fine on my CoreI3
> Clarkdale Laptop CPU J
> >  
> > Best regards
> > Atech
> 
(Continue reading)

Xiang, Haihao | 1 Feb 02:43 2012
Picon

Re: vaapi intel-driver (vaapi-ext): assertion failed

On Tue, 2012-01-31 at 17:32 +0100, Christoph Evers wrote: 
> Hi folks,
> 
> i am not sure whether this issue belongs to the libva mailinglist or 
> this one. I'll give it a try :-)

You can send all VAAPI related mail to libva <at> lists.freedesktop.org

> For testing purpose I switched to vaapi-ext branch of intel-driver and 
> libva (master is working fine).
> 
> I am using xine-lib-vaapi for playback with xine which uses a vaapi 
> accelerated ffmpeg: https://github.com/huceke/xine-lib-vaapi
> 
> H.264 (non interlaced) files are played fine, but with MPEG2 
> (interlaced/non-interlaced) the vaapi intel driver throws an exception:

Do you mean playing with a frame coded video also triggers the Assert?

> > xine: i965_drv_video.c:2075: i965_check_alloc_surface_bo: assertion 
> > obj_surface->fourcc == fourcc failed.
> 
> Obviously, the obj_surface fourcc (NV12) does not fit to the fourcc of 
> the media (I420).
> 

It seems there are other operations on this surface before decoding in
xine-lib-vaapi. I can't reproduce this issue with mplayer-vaapi

> If I force NV12 in i965_media_mpeg2.c:517 playback is working (even 
(Continue reading)

zhigang.gong | 1 Feb 12:47 2012
Picon

[PATCH] uxa/glamor: Refine CloseScreen and InitScreen process.

From: Zhigang Gong <zhigang.gong <at> linux.intel.com>

The previous version calls glamor_egl_close_screen and
glamor_egl_free_screen manually which is not align with
standard process. Now glamor change the way to follow
standard method:

glamor layer and glamor egl layer both have their internal
CloseScreens. The correct sequence is after the I830CloseScreen
is registered, then register glamor_egl_close_screen and
the last one is glamor_close_screen. So we move out the
intel_glamor_init from the intel_uxa_init to I830ScreenInit
and just after the registration of I830CloseScreen.

As the glamor interfaces changed, we need to check the
glamor version when load the glamor egl module to make
sure we are loading the right glamor module. If
failed, it will switch back to UXA path.

Signed-off-by: Zhigang Gong <zhigang.gong <at> linux.intel.com>
---
 src/intel_driver.c |    3 +-
 src/intel_glamor.c |   66 +++++++++++++++++++++++++++------------------------
 src/intel_uxa.c    |    2 -
 uxa/uxa.h          |   10 ++++++-
 4 files changed, 44 insertions(+), 37 deletions(-)

diff --git a/src/intel_driver.c b/src/intel_driver.c
index 9d1c4e8..d66a8fd 100644
--- a/src/intel_driver.c
(Continue reading)

alanwww1 | 1 Feb 13:16 2012
Picon

Re: VAAPI (master or ext) no deinterlacing with Clarkdale GPU

Hi  Christoph !


For the stuttering problem it is cause by lack of shader horse power to use HQ upsacling AND deinterlacing together.
Please try to set the upscaler from auto to "bilinear" or even "nearest" at the worst case.
Also if you are using xbmc in a composited environment please turn off all compositing or even try to run xbmc in a separate Xsession.

If that does not help, you probably will never have it working stutter-free with Clarkdale.

Cheers,

Attila (Team XBMC)

2012/2/1 Xiang, Haihao <haihao.xiang <at> intel.com>
Hi,

  I know what is the problem. For some reason, the native pixel format
for MPEG-2 decoding on Clarkdale is I420, however the input pixel format
of deinterlacing is NV12 in the driver, so the driver doesn't support
deinterlacing for MPEG-2 on Clardale. We will try to fix this issue but
don't expect it too soon.

BTW you can send all VAAPI related mail to libva <at> lists.freedesktop.org
as well.

Thanks
Haihao

> Atechsystem <Atechsystem <at> freenet.de> writes:
>
> >
> >
> > Hello,
> >
> > I’ve written an email to Haihao Xiang regarding the “no deinterlacing” bug on
> Clarkdale a week ago and he answered today. He will check this issue. I’ll hope
> he can fix it. Will the extended vaapi-ext deinterlacers (temporal or spatial I
> guess) also be available on Clarkdale platform? I tried the extended DXVA
> hardware deinterlacing on Windows today and it worked fine on my CoreI3
> Clarkdale Laptop CPU J
> >
> > Best regards
> > Atech
>
>
> Hi Atech,
>
> same problem over here. I am on vaapi-ext and latest xbmc. I can select Bob and
> Bob (inverted) as deinterlacers in xbmc. With MPEG2 material deinterlacing
> doesn't work at all. With H.264 video it seems to deinterlace, but video is
> stuttering and I have lots of frame drops.
>
> Hardware: Core i3 530
> Software: Ubuntu 11.11 x86 minimal with latest xorg stuff (edgers:ppa) and
> vaapi-ext branch for libva and intel-vaapi
>
> Regards,
> Christoph / Flachzange
>
>
>
>
> _______________________________________________
> Intel-gfx mailing list
> Intel-gfx <at> lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/intel-gfx


_______________________________________________
Intel-gfx mailing list
Intel-gfx <at> lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/intel-gfx

_______________________________________________
Intel-gfx mailing list
Intel-gfx <at> lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/intel-gfx
Christoph Evers | 1 Feb 14:01 2012
Picon

Re: VAAPI (master or ext) no deinterlacing with Clarkdale GPU

Hi Attila!

Am 01.02.2012 13:16, schrieb alanwww1:
> Hi  Christoph !
>
> For the stuttering problem it is cause by lack of shader horse power 
> to use HQ upsacling AND deinterlacing together.

Yes, I noticed this in the meanwhile. GPU top showed me 100% usage :-)

> Please try to set the upscaler from auto to "bilinear" or even 
> "nearest" at the worst case.

It already was bilinear, but even nearest does not help

> Also if you are using xbmc in a composited environment please turn off 
> all compositing or even try to run xbmc in a separate Xsession.

No composite environment, but openbox window manager
>
> If that does not help, you probably will never have it working 
> stutter-free with Clarkdale.
>

Yes probably, even with mplayer no chance (68% framedrops)

Thanks!
Christoph
Ben Guthro | 1 Feb 16:24 2012
Picon

Ironlake eDP training broken in 3.2.2

I'm moving my company's distro from 2.6.38 to 3.2.X  (currently 3.2.2)
- and have found a regression in i915 that I'm hoping someone here
might have a fix for, already.

On some older platforms, I'm seeing the stack below that results in
the screen never showing anything.

Any thoughts, patches, suggestions are appreciated.

- Ben Guthro

[   28.064432] ------------[ cut here ]------------
[   28.064468] WARNING: at
/builds/orc-precise/linux-3.2/drivers/gpu/drm/i915/intel_dp.c:1071
ironlake_edp_panel_vdd_off+0xbf/0xd0 [i915]()
[   28.064472] Hardware name: Latitude E5510
[   28.064474] eDP VDD not forced on
[   28.064475] Modules linked in: iptable_nat nf_nat nf_conntrack_ipv4
nf_conntrack scst_vdisk(O) nf_defrag_ipv4 crc32c ip_tables libcrc32c
x_tables scst_cdrom(O) scst(O) bridge stp llc microcode iscsi_tcp
libiscsi_tcp libiscsi scsi_transport_iscsi nfsd arc4 exportfs nfs
snd_hda_codec_hdmi snd_hda_codec_idt snd_hda_intel snd_hda_codec lockd
iwlwifi(O) fscache auth_rpcgss psmouse snd_hwdep nfs_acl snd_pcm
dell_laptop dell_wmi serio_raw snd_timer sparse_keymap dcdbas snd
mac80211(O) sunrpc soundcore snd_page_alloc intel_ips ppdev
cfg80211(O) parport_pc parport tpm_tis tpm tpm_bios usbhid hid zram(C)
i915 tg3 ehci_hcd sdhci_pci sdhci drm_kms_helper drm intel_agp
i2c_algo_bit intel_gtt video
[   28.064546] Pid: 309, comm: plymouthd Tainted: G        WC O 3.2.2-orc #1
[   28.064548] Call Trace:
[   28.064557]  [<ffffffff8106233f>] warn_slowpath_common+0x7f/0xc0
[   28.064561]  [<ffffffff81062436>] warn_slowpath_fmt+0x46/0x50
[   28.064573]  [<ffffffffa00cf79f>] ironlake_edp_panel_vdd_off+0xbf/0xd0 [i915]
[   28.064584]  [<ffffffffa00cf7ff>] intel_dp_commit+0x4f/0xb0 [i915]
[   28.064590]  [<ffffffffa00700bb>]
drm_crtc_helper_set_mode+0x4eb/0x520 [drm_kms_helper]
[   28.064597]  [<ffffffffa0070fbf>]
drm_crtc_helper_set_config+0x83f/0xaf0 [drm_kms_helper]
[   28.064603]  [<ffffffffa006dcc0>]
drm_fb_helper_restore_fbdev_mode+0x40/0x60 [drm_kms_helper]
[   28.064614]  [<ffffffffa00d77bc>] intel_fb_restore_mode+0x1c/0x50 [i915]
[   28.064623]  [<ffffffffa00a0da9>] i915_driver_lastclose+0x39/0x80 [i915]
[   28.064635]  [<ffffffffa0022699>] drm_lastclose+0x49/0x300 [drm]
[   28.064643]  [<ffffffffa002370d>] drm_release+0x4fd/0x6c0 [drm]
[   28.064648]  [<ffffffff81164f5a>] fput+0xea/0x220
[   28.064651]  [<ffffffff81161926>] filp_close+0x66/0x90
[   28.064654]  [<ffffffff81161a02>] sys_close+0xb2/0x120
[   28.064660]  [<ffffffff8157f7c2>] system_call_fastpath+0x16/0x1b
[   28.064662] ---[ end trace 4d53f99c84fca531 ]---
Ben Guthro | 1 Feb 17:48 2012
Picon

Re: Ironlake eDP training broken in 3.2.2

FWIW, I found the following patch that seems to solve the issue, on
this platform:

https://bugs.freedesktop.org/attachment.cgi?id=56178

linked from:
https://bugs.freedesktop.org/show_bug.cgi?id=42263

I was unable to find this committed in any of the dev trees, however.

Does this have any known issues on other platforms?

On Wed, Feb 1, 2012 at 10:17 AM, Ben Guthro <ben <at> guthro.net> wrote:
> I'm moving my company's distro from 2.6.38 to 3.2.X  (currently 3.2.2)
> - and have found a regression in i915 that I'm hoping someone here
> might have a fix for, already.
>
> On some older platforms, I'm seeing the stack below that results in
> the screen never showing anything.
>
> Any thoughts, patches, suggestions are appreciated.
>
> - Ben Guthro
>
>
> [   28.064432] ------------[ cut here ]------------
> [   28.064468] WARNING: at
> /builds/orc-precise/linux-3.2/drivers/gpu/drm/i915/intel_dp.c:1071
> ironlake_edp_panel_vdd_off+0xbf/0xd0 [i915]()
> [   28.064472] Hardware name: Latitude E5510
> [   28.064474] eDP VDD not forced on
> [   28.064475] Modules linked in: iptable_nat nf_nat nf_conntrack_ipv4
> nf_conntrack scst_vdisk(O) nf_defrag_ipv4 crc32c ip_tables libcrc32c
> x_tables scst_cdrom(O) scst(O) bridge stp llc microcode iscsi_tcp
> libiscsi_tcp libiscsi scsi_transport_iscsi nfsd arc4 exportfs nfs
> snd_hda_codec_hdmi snd_hda_codec_idt snd_hda_intel snd_hda_codec lockd
> iwlwifi(O) fscache auth_rpcgss psmouse snd_hwdep nfs_acl snd_pcm
> dell_laptop dell_wmi serio_raw snd_timer sparse_keymap dcdbas snd
> mac80211(O) sunrpc soundcore snd_page_alloc intel_ips ppdev
> cfg80211(O) parport_pc parport tpm_tis tpm tpm_bios usbhid hid zram(C)
> i915 tg3 ehci_hcd sdhci_pci sdhci drm_kms_helper drm intel_agp
> i2c_algo_bit intel_gtt video
> [   28.064546] Pid: 309, comm: plymouthd Tainted: G        WC O 3.2.2-orc #1
> [   28.064548] Call Trace:
> [   28.064557]  [<ffffffff8106233f>] warn_slowpath_common+0x7f/0xc0
> [   28.064561]  [<ffffffff81062436>] warn_slowpath_fmt+0x46/0x50
> [   28.064573]  [<ffffffffa00cf79f>] ironlake_edp_panel_vdd_off+0xbf/0xd0 [i915]
> [   28.064584]  [<ffffffffa00cf7ff>] intel_dp_commit+0x4f/0xb0 [i915]
> [   28.064590]  [<ffffffffa00700bb>]
> drm_crtc_helper_set_mode+0x4eb/0x520 [drm_kms_helper]
> [   28.064597]  [<ffffffffa0070fbf>]
> drm_crtc_helper_set_config+0x83f/0xaf0 [drm_kms_helper]
> [   28.064603]  [<ffffffffa006dcc0>]
> drm_fb_helper_restore_fbdev_mode+0x40/0x60 [drm_kms_helper]
> [   28.064614]  [<ffffffffa00d77bc>] intel_fb_restore_mode+0x1c/0x50 [i915]
> [   28.064623]  [<ffffffffa00a0da9>] i915_driver_lastclose+0x39/0x80 [i915]
> [   28.064635]  [<ffffffffa0022699>] drm_lastclose+0x49/0x300 [drm]
> [   28.064643]  [<ffffffffa002370d>] drm_release+0x4fd/0x6c0 [drm]
> [   28.064648]  [<ffffffff81164f5a>] fput+0xea/0x220
> [   28.064651]  [<ffffffff81161926>] filp_close+0x66/0x90
> [   28.064654]  [<ffffffff81161a02>] sys_close+0xb2/0x120
> [   28.064660]  [<ffffffff8157f7c2>] system_call_fastpath+0x16/0x1b
> [   28.064662] ---[ end trace 4d53f99c84fca531 ]---
Daniel Vetter | 1 Feb 17:55 2012
Picon

Re: Ironlake eDP training broken in 3.2.2

On Wed, Feb 01, 2012 at 11:48:07AM -0500, Ben Guthro wrote:
> FWIW, I found the following patch that seems to solve the issue, on
> this platform:
> 
> https://bugs.freedesktop.org/attachment.cgi?id=56178
> 
> linked from:
> https://bugs.freedesktop.org/show_bug.cgi?id=42263
> 
> I was unable to find this committed in any of the dev trees, however.
> 
> Does this have any known issues on other platforms?

This patch is simply still under review and testing, so if you can, please
test it. You need the latest drm-intel-fixes branch from:

https://git.kernel.org/?p=linux/kernel/git/keithp/linux.git;a=summary

Then apply the patch you've linked to manually. If that does not help,
please file a new bug report on bugs.freedesktop.org against drm/intel.
Atm many people are already travelling to fosdem, so it could get lost.

Yours, Daniel
--

-- 
Daniel Vetter
Mail: daniel <at> ffwll.ch
Mobile: +41 (0)79 365 57 48
atechsystem | 1 Feb 19:06 2012
Picon

Re: [Libva] FW: vaapi intel-driver (vaapi-ext): assertion failed

Hello,

i can reproduce this issue as he described. If I follow his instructions i get interlaced mpeg2 output with
wrong colors (also with mplayer-vaapi). But i cannnot reproduce the "xine: i965_drv_video.c:2075:>
i965_check_alloc_surface_bo: assertion" error with non changed vaapi-ext suorces. I don't get this
error displayed.

Meanwhile i checked vaap-ext deinterlacing output with h264 i file Slices from here:

http://www.avsforum.com/avs-vb/showthread.php?p=16900173#post16900173

XBMC and mplayer-vaapi show deinterlaced output with many framedrops (Christoph Evers allready
reported). I checked it on my I3 540 and I5 661 CPU's but even the faster CPU with 900MHZ videoclock is too
slow. 

Regards
Atech 

> -----Ursprüngliche Nachricht-----
> Von: Xiang Haihao 
> Gesendet: Wed. 01.02.2012 03:34
> An: atechsystem <at> freenet.de
> Kopie: libva <at> lists.freedesktop.org
> Betreff: Re: [Libva] FW: [Intel-gfx] vaapi intel-driver (vaapi-ext): assertion failed
>
> On Wed, 2012-02-01 at 10:32 +0800, Xiang, Haihao wrote: 
> > On Tue, 2012-01-31 at 22:48 +0100, atechsystem <at> freenet.de wrote: 
> > > Hello,
> > >
> > > I forward it to the vaapi mailinglist to get sure. 
> > >
> > > I will try to reproduce this attitude to check if I get also
> deinterlaced output with or without the wrong color space. Till now
> I've not seen the "xine: i965_drv_video.c:2075:
> i965_check_alloc_surface_bo: assertion" error message,
> >
> > Do you mean you can reproduce this issue any more? I can't
> reproduce
>                  ^^^^^^^^^     
>        typo :(, can not
>
>
> > this issue with other players, such as VLC, mplayer.
> >
> > > only non interlaced output. 
> >
> > Yes for MPEG-2 video.
> >
> >
> > >
> > > Best regards
> > > Atech 
> > >
> > > > > -----weitergeleitete Nachricht-----
> > > > > Von: Christoph Evers 
> > > > > Gesendet: Tue. 31.01.2012 17:32
> > > > > An: intel-gfx <at> lists.freedesktop.org
> > > > > Betreff: [Intel-gfx] vaapi intel-driver (vaapi-ext):
> assertion
> > > > failed
> > > > >
> > > > > Hi folks,
> > > > >
> > > > > i am not sure whether this issue belongs to the libva
> mailinglist
> > > > or
> > > > > this one. I'll give it a try :-)
> > > > >
> > > > > For testing purpose I switched to vaapi-ext branch of
> intel-driver
> > > > > and
> > > > > libva (master is working fine).
> > > > >
> > > > > I am using xine-lib-vaapi for playback with xine which uses a
> > > > vaapi
> > > > > accelerated ffmpeg: https://github.com/huceke/xine-lib-vaapi
> > > > >
> > > > > H.264 (non interlaced) files are played fine, but with MPEG2
> > > > > (interlaced/non-interlaced) the vaapi intel driver throws an
> > > > > exception:
> > > > >
> > > > > > xine: i965_drv_video.c:2075: i965_check_alloc_surface_bo:
> > > > assertion
> > > > > > obj_surface->fourcc == fourcc failed.
> > > > >
> > > > > Obviously, the obj_surface fourcc (NV12) does not fit to the
> > > > fourcc
> > > > > of
> > > > > the media (I420).
> > > > >
> > > > > If I force NV12 in i965_media_mpeg2.c:517 playback is working
> > > > (even
> > > > > deinterlaced on Clarkdale) but naturally with the wrong color
> > > > space.
> > > > >
> > > > > Do you guys have any idea?
> > > > >
> > > > > Christoph
> > > > >
> > > > > Hardware: Core i3 530
> > > > > Software: Ubuntu 11.11 x86 minimal with latest xorg stuff
> > > > > (edgers:ppa) and
> > > > > vaapi-ext branch for libva and intel-vaapi (git 30012012)
> > > > >
> > > > >
> > > > > _______________________________________________
> > > > > Intel-gfx mailing list
> > > > > Intel-gfx <at> lists.freedesktop.org
> > > > > http://lists.freedesktop.org/mailman/listinfo/intel-gfx
> > > > >
> > > > >
> > > > > -----weitergeleitete Nachricht Ende-----
> > > >
> > > >
> > > >
> > > >
> > > > ---
> > > > Nutzen Sie freenet Mail optimal angepasst für Ihr iPhone,
> Android
> > > > oder Nokia Handy auch von unterwegs.
> > > > Alle Infos und Download unter
> > > > http://mail.freenet.de/mobile-email/index.html
> > > >
> > > >
> > > > -----weitergeleitete Nachricht Ende-----
> > >
> > >
> > >
> > >
> > > ---
> > > E-Mail ist da wo du bist! Jetzt mit freenetMail ganz bequem auch
> unterwegs E-Mails verschicken.
> > > Am besten gleich informieren unter
> http://mail.freenet.de/mobile-email/index.html
> > > _______________________________________________
> > > Libva mailing list
> > > Libva <at> lists.freedesktop.org
> > > http://lists.freedesktop.org/mailman/listinfo/libva
> >
> >
> > _______________________________________________
> > Libva mailing list
> > Libva <at> lists.freedesktop.org
> > http://lists.freedesktop.org/mailman/listinfo/libva
>
>
> _______________________________________________
> Libva mailing list
> Libva <at> lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/libva>
>
> -----Ursprüngliche Nachricht Ende-----

---
Nutzen Sie freenet Mail optimal angepasst für Ihr iPhone, Android oder Nokia Handy auch von unterwegs.
Alle Infos und Download unter http://mail.freenet.de/mobile-email/index.html
atechsystem | 1 Feb 19:47 2012
Picon

FW: RE: Re: VAAPI (master or ext) no deinterlacing with Clarkdale GPU

Hello,

I tried the same (Slicies H.264 PAL 1080i-25.ts):

Unsupported PixelFormat 61
[VD_FFMPEG] Trying pixfmt=1.
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [vaapi] 1920x1080 => 1920x1080 H.264 
VA-API Acceleration 
[VD_FFMPEG] XVMC-accelerated MPEG-2.> A: 622.5 V: 633.8 A-V:-11.267 ct: -2.039 844/844 21% 78% 0.1% 417 0 
TS_PARSE: COULDN'T SYNC
A: 633.5 V: 633.8 A-V: -0.320 ct:-13.047 844/844 21% 78% 0.2% 417 0 

BENCHMARKs: VC: 4.482s VO: 16.106s A: 0.042s Sys: 12.851s = 33.481s
BENCHMARK%: VC: 13.3871% VO: 48.1047% A: 0.1253% Sys: 38.3829% =
100.0000%
BENCHMARKn: disp: 427 (12.75 fps) drop: 417 (49%) total: 844 (25.21
fps)

Exiting... (End of file)

 49% framedrops on my I5 661. 

I tested this file also on my Arrandale i3 350 and it worked pretty
well with windows 7 xbmc and dxva deinterlacing only 7 framedrops at beginning.

Best regards
Atech

> > -----Ursprüngliche Nachricht-----
> > Von: Christoph Evers 
> > Gesendet: Wed. 01.02.2012 14:01
> > An: alanwww1 
> > Kopie: intel-gfx <at> lists.freedesktop.org
> > Betreff: Re: [Intel-gfx] VAAPI (master or ext) no deinterlacing
> with Clarkdale GPU
> >
> > Hi Attila!
> >
> > Am 01.02.2012 13:16, schrieb alanwww1:
> > > Hi  Christoph !
> > >
> > > For the stuttering problem it is cause by lack of shader horse
> > power
> > > to use HQ upsacling AND deinterlacing together.
> >
> > Yes, I noticed this in the meanwhile. GPU top showed me 100% usage
> > :-)
> >
> > > Please try to set the upscaler from auto to "bilinear" or even
> > > "nearest" at the worst case.
> >
> > It already was bilinear, but even nearest does not help
> >
> > > Also if you are using xbmc in a composited environment please
> turn
> > off
> > > all compositing or even try to run xbmc in a separate Xsession.
> >
> > No composite environment, but openbox window manager
> > >
> > > If that does not help, you probably will never have it working
> > > stutter-free with Clarkdale.
> > >
> >
> > Yes probably, even with mplayer no chance (68% framedrops)
> >
> > Thanks!
> > Christoph
> >
> > _______________________________________________
> > Intel-gfx mailing list
> > Intel-gfx <at> lists.freedesktop.org
> > http://lists.freedesktop.org/mailman/listinfo/intel-gfx
> >
> >
> > -----Ursprüngliche Nachricht Ende-----
>
>
>
>
> ---
> Nutzen Sie freenet Mail optimal angepasst für Ihr iPhone, Android
> oder Nokia Handy auch von unterwegs.
> Alle Infos und Download unter
> http://mail.freenet.de/mobile-email/index.html
>
>
> -----weitergeleitete Nachricht Ende-----

---
Nutzen Sie freenet Mail optimal angepasst für Ihr iPhone, Android oder Nokia Handy auch von unterwegs.
Alle Infos und Download unter http://mail.freenet.de/mobile-email/index.html

Gmane