Dominique Michel | 29 Jan 17:22 2016

keyboard issue when resuming from hibernate/resume

Hi all,

With an Acer Aspire, the mouse and the keyboard are dead after
resuming. The loaded modules are:

# lsmod | grep i8042
i8042                  13006  1 libps2
# lsmod | grep libps2
libps2                  4139  2 atkbd,psmouse
i8042                  13006  1 libps2

In /etc/conf.d/modules :

- gentoo without systemd and *kit

- At "normal" boot, I use startx, and the keyboard is working fine.
  After the launch of X and fvwm-crystal, both the keyboard and the
  mouse are OK.

After resuming from hibernation, the keyboard and the mouse are dead
most of the time. An external USB mouse was still working, and after a
few suspend/resume cycles, they come back.

Thanks to the external USB mouse, I was able to narrow the issue to the
atkbd and psmouse module:

# rmmod atkbd; rmmod psmouse
-> keyboard and mouse dead

(Continue reading)

Juanjo Gomez Navarro | 1 Apr 11:06 2015

Issue waking up Lenovo X1 Carbon laptop

Good morning,

I'm having some problems with the suspend of a Lenovo laptop (3rd generation of X1 Carbon). Using Gnome in Opensuse 13.2, I can set in suspend mode. It also wakes up normally opening the lid, and everything seems to work OK. However, when the laptop is suspend overnight, it does not wake any more. I have to switch it off by long-pressing the power button. Somehow, the time the laptop is in suspend mode plays a role in the wake up process.

Any idea if what could be going wrong? I attach the content of the /var/log/pm-suspend.log file just after booting the computer after having switched off by hard. I do not see anything estrange.

PS: additionally, the power button does not trigger suspend, only manual suspend through Gnome or closing the lid does.

Thank you very much.

Juan José Gómez-Navarro

University of Bern
Physics Institute
Sidlerstrasse 5
CH-3012 Bern
Attachment (pm-suspend.log): text/x-log, 9 KiB
Pm-utils mailing list
Pm-utils <at>
Weedy | 4 Mar 13:37 2015

Resuming from suspend with binary Nvidia driver

Somewhere in last months update marathon resuming broke.
I'm not sure it was 3.17.x -> 3.18.x or nvidia-drivers-340.65 to
nvidia-drivers-340.76, but now I get stuck at a black screen like half
the time I resume.

Dell M6300
NVIDIA Corporation G92GLM [Quadro FX 3600M] (about a 8800M, G92 architecture)

I've found some forum posts about NVAGP in xorg.conf and
Is any of this still relevant in todays ecosystem? How should I go
about debugging exactly what quirk or option I need when I have a
black screen and a locked up system?
I've downgraded back to nvidia-drivers-340.65. Resume is still broken
but it's 1 in 10 no 4-5 in 10 resumes.

Thank you for your time.
Pm-utils mailing list
Pm-utils <at>
Wirawan Purwanto | 13 Feb 01:56 2014

Who sleeps me? Who wakes me?


Given a typical linux desktop setup, I want to know which hardware or
software event
causes (triggers) suspend or resume of a laptop. For example, in
Lenovo T400 laptop, an external USB keyboard (already plugged into a
laptop prior to suspending) keypress will cause the laptop to wake up.
is there a way to know that this "wake up" is caused by this keypress?
Or maybe it was caused by lid event (lid being closed or opened). I
know this is a complicated chain.
But occasionally I am facing a mysterious laptop waking up itself from
sleep (sleep-to-RAM) and I don't know what causing it. My OS is Debian
7 (stable, wheezy) x86-64.

Wirawan Purwanto
Research Scientist
College of William and Mary
Physics Department
Williamsburg, VA 23187
Tomas Davidek | 1 Nov 12:42 2013

pm-hibernate on a Lenovo T431s

Dear all,
     I got a new laptop Lenovo T431s and I am fighting a lot with 

When trying simply pm-hibernate from text console, the system apparently 
saves the image to swap and powers off. That's ok. But when booting 
again, the last message on the screen is
Booting the kernel.
Loading, please wait...

I expected more info, since I set PM_DEBUG="true" in 

Anyway, looking in the log (/var/log/pm-suspend.log) there are thousands 
of messages, it finishes with:
+ inhibited
+ [ -f /var/run/pm-utils/pm-suspend/storage/inhibit ]
+ return 0
+ date
+ log Fri Nov  1 12:19:11 CET 2013: performing hibernate
+ is_set true
+ return 0
+ local fmt=%s\n
+ [ Fri Nov  1 12:19:11 CET 2013: performing hibernate = -n ]
+ printf %s\n Fri Nov  1 12:19:11 CET 2013: performing hibernate
Fri Nov  1 12:19:11 CET 2013: performing hibernate
+ sync
+ do_hibernate
+ [ -n  ]
+ echo -n disk

Sounds like there is no message from the resume process? GRUB is set 
with resume:swap=/dev/sda7, so this should be ok too....

This has been obtained with purely pm-utils,  without hibernate & 
uswsusp installed. I also tried with uswsusp installed, the behaviour is 
similar, the resume process hangs at similar message
resume: image successfully loaded

Frankly speaking, I don't understand the interplay between pm-utils and 
swsusp, I thought these are different front-ends?

Thanks a lot for any hint in advance,

Tomas Davidek | 25 Oct 14:06 2013

displaying progress

    when launching pm-hibernate, the display just blinks once, then 
nothing seems to be happening (well, I see the disk activity, so the 
system is really storing the memory image on swap) and then suddenly the 
system powers off. Everything works well, but I would prefer that the 
system shows the status. A simple option would be to switch to text 
console (chvt 1) and show the progress in percentage.

Is there a way to set this feature in pm-utils?

Best regards,
Michel DEVEL | 21 Oct 03:23 2013

Black unresponsive screen after hibernate/thaw presumably due to NVIDIA driver

Dear pm-utils users and developers,

This is my first mail on this list so I present myself a bit:
I am a long time user of opensuse at work and at home, but I am only a user and certainly not a system expert, so that even after reading some of the documentation for the opensuse implementation of pm-utils, I still have problems to be able to sort out by myself a problem with pm-utils.

I have had a problem with hibernate/resume on my computer since at least the default pm-utils that was integrated in opensuse 11.4 until now (12.3)! (In fact I do not remember that it ever worked for me). The problem is that I usually have plenty of softs and at least one virtual machine opened at the same time (I have 24 GB of RAM) so that I almost never shutdown and reboot my PC and have very rarely the occasion and time to experiment with hibernate.
Hence, if you solve the following problem, you will also make a good action for the planet since I will be able to use hibernation at the end of every working day!

The current version of pm-utils on my PC is   1.4.1-26.17.1

p, li { white-space: pre-wrap; }

The hibernate and resume just go on all right (success at the end of pm-suspend.log and 100% of data image loaded) but I get a black screen afterward (and neither Ctrl-Alt-F1 to F12 works nor Ctrl-Alt-Esc or Ctrl-Alt-Del).

By checking Xorg.0.log against Xorg.0.log.old, I see that at the end after the EDID checks I have
[ 4863.515] (II) Open ACPI successful (/var/run/acpid.socket)
[ 4863.592] (WW) NVIDIA(GPU-0): Failed to enter interactive mode.
[ 4863.592] (EE) NVIDIA(GPU-0): Failed to determine display capabilities
[ 4863.592] (EE) *** Aborting ***
[ 4863.592]
Fatal server error:
[ 4863.592] EnterVT failed for screen 0
[ 4863.592]
[ 4863.592] (EE)
Please consult the The X.Org Foundation support
at xorg
for help.
[ 4863.592] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 4863.592] (EE)
[ 4863.594] (II) evdev: Logitech HID compliant keyboard: Close
[ 4863.594] (II) UnloadModule: "evdev"
[ 4863.594] (II) evdev: Logitech HID compliant keyboard: Close
[ 4863.595] (II) UnloadModule: "evdev"
[ 4863.596] (II) evdev: Microsoft Corporation Microsoft ® Laser Mouse 6000: Close
[ 4863.596] (II) UnloadModule: "evdev"
[ 4863.596] (II) evdev: STV06xx: Close
[ 4863.596] (II) UnloadModule: "evdev"
[ 4863.597] (II) evdev: Power Button: Close
[ 4863.597] (II) UnloadModule: "evdev"
[ 4863.597] (II) evdev: Power Button: Close
[ 4863.597] (II) UnloadModule: "evdev"

I have tried to google "(EE) NVIDIA(GPU-0): Failed to determine display capabilities" but the only reference are for my former posts on the opensuse forums

My graphics card is a GTX260 and I use x11-video-nvidiaG03, nvidia-gfx03-kmp-desktop and nvidia-computeG03 from obs:// though I do not have this repo in my list (I have ...

I have tried to create a script named first 99znvidia the 99nvidia with

. $PM_UTILS_LIBDIR/functions

case "$1" in
modunload nvidia
modreload nvidia

exit 0

The script was executed during hibernate and thaw with success, but my screen stayed black and unresponsive after the image was loaded into memory and pm_suspend.log contains only success.

Any help will be appreciated.

Pm-utils mailing list
Pm-utils <at>
Nisha gunasekaran | 8 Oct 13:48 2013

Error while compiling after clean version-1.4.1

Hi all,

I have downloaded pm-utils-1.4.1. compiled and tested, It worked properly.
But the problem is, second make fails after make clean. I'm getting the following message.

make[2]: *** No rule to make target `service', needed by `all-am'.  Stop.

I have removed service from script_in_files(src/ Now it compiles.

Also i've checked the earlier version, this service clean was not there.

Is it okay to remove the service script from cleaning? Otherwise guide me in the right way.

Nisha K

Pm-utils mailing list
Pm-utils <at>
Rheinländer | 27 Nov 04:34 2012

Prevent PCMCIA power-off


how would I prevent pm-suspend from powering off my PCMCIA/cardbus cards? I have a network card in there and powering it off prevents Wake-on-lan.


Pm-utils mailing list
Pm-utils <at>
CG | 20 Nov 22:38 2012

fixing (an almost fixed) suspend of the asus 1025c

Hardware/software context
Machine: ASUS eee pc 1025C
CPU: N2800
Integrated graphics processor: Intel GMA3650
OS: Ubuntu 12.04 LTS
kernel: 3.4.0-0304000-generic (note: I upgraded to a newer kernel than
the standard kernel packaged with Ubuntu 12.04. This was required to
exploit several features of the GMA3650.)

suspend is broken (but almost fixed).

pm-suspend => garbled screen after wake up

pm-suspend --quirk-vbemode-restore => after wake up, screen is black
(that is, the active-type-of-black: the backlight is on). Moving mouse
or keyboard doesn't change anything. This is the case until the default
screen saver becomes active. Then the screen goes completely dark
(backlight off) and after that, moving mouse or keyboard brings back a
visible, and completely correct screen.

I also tried other combinations of quirks, but the results were in each
case one of the above.

How can suspend be fixed? The screensaver apparently does something good
to the state of the graphics system, but what is it? I tried to simulate
it with calling the screensaver directly from the command line
(gnome-screensaver-command -a), but that didn't work (it didn't have the
same positive effect as the default screensaver which becomes active
automatically after X minutes).

Thanks in advance!

Athlion | 22 Jul 17:59 2012

Lenovo T420 issues

Hello all. I have a Lenovo T420 with the integrated intel HD3000 card
(no optimus) and have issues suspending the laptop. What happens is,
briefly, that after I've been using the laptop for about a day or two
(suspending/resuming with no problems) the suspend fails and the sleep
led will start flashing constantly. If I open the lid, I see that X
has dropped back to the display manager and no suspension has taken
place. You can see the thread I have opened in arch linux forums here:

What's more interesting is that if I try to reboot after the failed
suspend, the system starts rebooting, suspends correctly midway and
finishes the reboot upon resuming.

I am trying to figure the source of this problem as this affects other
laptops as well and in the process I have enabled PM_DEBUG and
collected the /var/log/pm-suspend.log from an OK and from a failed
one. You can find them here:
Not OK:

There are a couple of interesting points to notice
1. One glaring difference is that they differ only in the initial
active/not active (which I believe is referring to laptop_mode_tools)
- But this thing happens to users having completely removed laptop
mode tools, so this doesn't seem to be relevant
2. They are the same up to line 381 (when the OK version ends). What
goes beyond that in the not ok is beyond my comprehension....

Can anyone offer any help or info on what's going on and how I can
track the problem?