Des Dougan | 1 Aug 03:43 2005

Re: Problem with SuSE 9.3

On Sun, 2005-07-31 at 10:51 -0700, ace jones wrote:
> On Fri, 2005-07-29 at 22:11, Des Dougan wrote:
> > I recently upgraded from SuSE 9.1 to 9.3 (libofx-0.7.0-3;
> > gnucash-1.8.9-8). When I try to import my bank account transactions
> > (Royal Bank of Canada), I get the following:
> > 
> > LibOFX ERROR: ofx_proc_file():No input file specified
> > (Above message occured on Line 4294967295, Column 4294967295)
> > 
> > Needless to say, it worked fine with SuSE 9.1...
> > 
> > I've Googled for anything on this - no luck. 
> > 
> > I'd appreciate any help on this and will gladly help debug it if this
> > would be of use.
> 
> Hi, Des.  What program are you running?  This may be a problem of the
> host application.
> 
> Could you please try running ofxdump on your file and see what it comes
> back with?
> 
> </Ace>

I'm running gnucash 1.8.9-8 (which shipped with SuSE 9.3).

ofxdump on my file shows the following:

p133:/home/des # ofxdump ofx39940.qfx
LibOFX INFO: libofx_proc_file(): File format not specified,
(Continue reading)

ace jones | 1 Aug 06:22 2005

Re: Problem with SuSE 9.3

Hi, Des.  This points clearly at GnuCash, sorry.  If ofxdump works, then
the library appears to be parsing it fine.  The error seems to back this
up.  "ofx_proc_file():No input file specified" would seem to be telling
us that no input file was given to libofx!

</Ace>

On Sun, 2005-07-31 at 18:43, Des Dougan wrote:
> On Sun, 2005-07-31 at 10:51 -0700, ace jones wrote:
> > On Fri, 2005-07-29 at 22:11, Des Dougan wrote:
> > > I recently upgraded from SuSE 9.1 to 9.3 (libofx-0.7.0-3;
> > > gnucash-1.8.9-8). When I try to import my bank account transactions
> > > (Royal Bank of Canada), I get the following:
> > > 
> > > LibOFX ERROR: ofx_proc_file():No input file specified
> > > (Above message occured on Line 4294967295, Column 4294967295)
> > > 
> > > Needless to say, it worked fine with SuSE 9.1...
> > Hi, Des.  What program are you running?  This may be a problem of the
> > host application.
> > 
> > Could you please try running ofxdump on your file and see what it comes
> > back with?
> > 
> > </Ace>
> 
> I'm running gnucash 1.8.9-8 (which shipped with SuSE 9.3).
> 
> ofxdump on my file shows the following:

(Continue reading)

Jerry Amundson | 1 Aug 08:52 2005

Re: OFX Plugin crash

ofxdump trace, stdout, stderr, and test file attached. Running fully updated 
FC4 :
libofx-devel-0.7.0-3
openjade-devel-1.3.2-16

Thanks,
jerry

---- Original message ----
Hmm, this looks like a configuration-specific problem in libofx's use of
OpenSP or in OpenSP itself.  Can you send your file & message to
libofx-devel <at> lists.sf.net ?  This way the other libofx developers can
have a look.

Note that ofxdump works fine for me on your file.

Can you figure out what version of OpenSP you have?  I'm running 1.5. 
It may be worth trying to upgrade OpenSP to this.

</Ace>

On Sun, 2005-07-31 at 20:12, Jerry Amundson wrote:
> On Sun July 31 2005 20:59, ace jones wrote:
> > Jerry, the backtrace posted with your original message points deep
> > inside the SGML parser in OpenSP.  Can you run "ofxdump" on your file
> > successfully?  If not, then it's not a KMM problem, it's a libOFX or
> > OpenSP problem.
> 
> ofxdump unsuccessful. Trace dump, stdout, and stderr attached. Also included 
> the test file, in case mail servers did something to the first one...
(Continue reading)

Benoit Grégoire | 1 Aug 16:21 2005
Picon
Picon

Re: Re: OFX Plugin crash

On August 1, 2005 02:52 am, Jerry Amundson wrote:
> ofxdump trace, stdout, stderr, and test file attached. Running fully
> updated FC4 :
> libofx-devel-0.7.0-3
> openjade-devel-1.3.2-16

You should have an OpenSP-devel package available somewhere.  Try to add that.
--

-- 
Benoit Grégoire, http://benoitg.coeus.ca/
Jerry Amundson | 1 Aug 17:03 2005
X-Face

Re: Re: OFX Plugin crash

On Mon August 1 2005 09:21, Benoit Grégoire wrote:
> On August 1, 2005 02:52 am, Jerry Amundson wrote:
> > ofxdump trace, stdout, stderr, and test file attached. Running
> > fully updated FC4 :
> > libofx-devel-0.7.0-3
> > openjade-devel-1.3.2-16
>
> You should have an OpenSP-devel package available somewhere.  Try to
> add that.

With FC4, openjade-devel supplies it...

jerry <at> elm:~$ rpm -qi openjade-devel
Name        : openjade-devel               Relocations: /usr
Version     : 1.3.2                             Vendor: Red Hat, Inc.
Release     : 16                            Build Date: Tue 01 Mar 2005 
12:05:27 PM CST
Install Date: Fri 29 Jul 2005 11:13:39 PM CDT      Build Host: 
tweety.build.redhat.com
Group       : Development/Libraries         Source RPM: 
openjade-1.3.2-16.src.rpm
Size        : 9339760                          License: Distributable
Signature   : DSA/SHA1, Fri 20 May 2005 02:42:45 PM CDT, Key ID 
b44269d04f2a6fd2
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : Files for developing applications that use 
openjade/OpenSP.
Description :
The header files, static library, libtool library and man pages for
developing applications that use openjade/OpenSP.
(Continue reading)

Benoit Grégoire | 1 Aug 18:16 2005
Picon
Picon

Re: Re: OFX Plugin crash

On August 1, 2005 11:03 am, Jerry Amundson wrote:
> On Mon August 1 2005 09:21, Benoit Grégoire wrote:
> > On August 1, 2005 02:52 am, Jerry Amundson wrote:
> > > ofxdump trace, stdout, stderr, and test file attached. Running
> > > fully updated FC4 :
> > > libofx-devel-0.7.0-3
> > > openjade-devel-1.3.2-16
> >
> > You should have an OpenSP-devel package available somewhere.  Try to
> > add that.
>
> With FC4, openjade-devel supplies it...

Try typing onsgmls -v

--

-- 
Benoit Grégoire, http://benoitg.coeus.ca/
Benoit Grégoire | 1 Aug 20:48 2005
Picon
Picon

Re: Re: OFX Plugin crash

On August 1, 2005 02:02 pm, Jerry Amundson wrote:
> On Mon August 1 2005 09:21, Benoit Grégoire wrote:
> > On August 1, 2005 02:52 am, Jerry Amundson wrote:
> > > ofxdump trace, stdout, stderr, and test file attached. Running
> > > fully updated FC4 :
> > > libofx-devel-0.7.0-3
> > > openjade-devel-1.3.2-16
> >
> > You should have an OpenSP-devel package available somewhere.  Try to
> > add that.
>
> jerry <at> elm:~$ onsgmls -v
> onsgmls:I: "OpenSP" version "1.5"

So at least it's the right version.

I don't know what's wrong, I suspect it's a package that wasn't properly 
recompiled when they updated the distro.
--

-- 
Benoit Grégoire, http://benoitg.coeus.ca/
Jerry Amundson | 1 Aug 20:02 2005
X-Face

Re: Re: OFX Plugin crash

On Mon August 1 2005 09:21, Benoit Grégoire wrote:
> On August 1, 2005 02:52 am, Jerry Amundson wrote:
> > ofxdump trace, stdout, stderr, and test file attached. Running
> > fully updated FC4 :
> > libofx-devel-0.7.0-3
> > openjade-devel-1.3.2-16
>
> You should have an OpenSP-devel package available somewhere.  Try to
> add that.

jerry <at> elm:~$ onsgmls -v
onsgmls:I: "OpenSP" version "1.5"

-------------------------------------------------------
SF.Net email is sponsored by: Discover Easy Linux Migration Strategies
from IBM. Find simple to follow Roadmaps, straightforward articles,
informative Webcasts and more! Get everything you need to get up to
speed, fast. http://ads.osdn.com/?ad_idt77&alloc_id492&op=click
Benoit Grégoire | 12 Aug 21:44 2005
Picon
Picon

Re: libofx version number in CVS?

On August 12, 2005 02:40 pm, Christian Stimming wrote:
> Hi Benoit,
>
> the latest libofx in CVS seems to have version number 0.7.99, although
> other packages (notably aqbanking) are already requiring a 0.8.0 version.
> Did you forget to commit the version number change? Or did this change only
> not yet propagate to the anonymus CVS? Anyway, thanks for a new release.
>
> Christian

I just checked, after almost two weeks it still didn't propagate...

Sourceforge is getting worse...
--

-- 
Benoit Grégoire, http://benoitg.coeus.ca/
ace jones | 14 Aug 05:22 2005

Re: Re: libofx version number in CVS?

On Fri, 2005-08-12 at 12:44, Benoit Grégoire wrote:
> On August 12, 2005 02:40 pm, Christian Stimming wrote:
> > Hi Benoit,
> >
> > the latest libofx in CVS seems to have version number 0.7.99, although
> > other packages (notably aqbanking) are already requiring a 0.8.0 version.
> > Did you forget to commit the version number change? Or did this change only
> > not yet propagate to the anonymus CVS? Anyway, thanks for a new release.
> >
> > Christian
> 
> I just checked, after almost two weeks it still didn't propagate...

Hey guys, sorry for the n00b question...  Package management is still a
little hazy for me.  How do I go about requiring a specific version of
libofx?

</Ace>

-------------------------------------------------------
SF.Net email is Sponsored by the Better Software Conference & EXPO
September 19-22, 2005 * San Francisco, CA * Development Lifecycle Practices
Agile & Plan-Driven Development * Managing Projects & Teams * Testing & QA
Security * Process Improvement & Measurement * http://www.sqe.com/bsce5sf

Gmane