William Estrada | 5 Sep 03:38 2006

1-wire-master.jpeg

Hi guys,

  I am totally lost here.  I want to build system console for a linksys wrt54g.  I think I
can do it with the 1-wire interface, like so:

  http://64.124.13.3/1-Wire/1-wire-master.jpeg

But I need help with the design.  If one of you kind soles out there can give me some helpful
hints or fill in the holes, I would be very appreciative.  I can handle the software part.

  I admit that I don't know what I am doing, so you don't need to tell me that, OK!   My reading 
and comprehension skills are compromised by my Dyslexia.  I'm not stupid, just disabled!

--

-- 
William Estrada

Email      : MrUmunhum at popdial dot com
Resume     : www.Mt-Umunhum-Wireless.net/resume/william_estrada.html
HTTP       : www.Mt-Umunhum-Wireless.net

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
Jan Kandziora | 5 Sep 10:43 2006
Picon
Picon

Re: 1-wire-master.jpeg

Am Dienstag, 5. September 2006 03:38 schrieb William Estrada:
>
>   I am totally lost here.  I want to build system console for a linksys
> wrt54g.  I think I can do it with the 1-wire interface, like so:
>
>   http://64.124.13.3/1-Wire/1-wire-master.jpeg
>
> But I need help with the design.  If one of you kind soles out there can
> give me some helpful hints or fill in the holes, I would be very
> appreciative.  I can handle the software part.
>
RS232 as a Onewire slave "feels" complicated to me. There are a lot of timing 
requirements for both RS232 and Onewire, and I'm pretty sure they don't mix 
very well. Bitbanging RS232 through onewire could work for lower speeds (300 
Baud or so), though.

Which kind of keyboard and display do you want to connect? There is already 
support for HD44780 based alphanumerical displays (available with up to 4x24 
chars) in owfs.

For the keyboard part, a simple matrix keyboard may be connected far more easy 
to onewire.

Kind regards

	Jan
--

-- 
Windows ist Kommunismus: Es hört sich gut an, funktioniert aber nicht.

-------------------------------------------------------------------------
(Continue reading)

E. Kastelijn | 5 Sep 22:18 2006
Picon

OWFS FC5: owfs does not return


Hi Guys,

I am running Fedora Core 5, with the DS9490R USB adaptor, a TAI-8520
temperature sensor and a TAI-8540 humidity sensor.
I downloaded and installed 'digitemp', and this reads my sensors fine.

With owfs I am having some more trouble.
The RPMs don't want to install:
--------------------------
# rpm -ivh owfs-fs-2.5p0-1.i586.rpm owfs-libs-2.5p0-1.i586.rpm
error: Failed dependencies:
        libresmgr.so.0.9.8 is needed by owfs-fs-2.5p0-1.i586
        libusb-0.1.4 is needed by owfs-fs-2.5p0-1.i586
--------------------------
I am running a higher version of libusb (0.1.11-2.2)
My RPMs:
libusb-0.1.11-2.2
libusb-devel-0.1.11-2.2
fuse-devel-2.5.3-1.fc5
fuse-libs-2.5.3-1.fc5
fuse-2.5.3-1.fc5

So I decided to download the source RPM and recompile that:
--------------------------
Making all in php
make[3]: Entering directory `/root/.rpm/BUILD/owfs-2.5p0/module/swig/php'
if /bin/sh ../../../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H
-I. -I. -I../../../src/include    -fexceptions -I.. -I../../../src/include
-I../../../module/owlib/src/include -D_FILE_OFFSET_BITS=64  -g -O2
(Continue reading)

Paul Alfille | 6 Sep 00:55 2006
Picon

Re: OWFS FC5: owfs does not return

I'll have to find the location of that libusb dependency.

For now, configure with "./configure --disable_swig"

Paul

On 9/5/06, E. Kastelijn <owfs <at> kastelijn.nu> wrote:

Hi Guys,

I am running Fedora Core 5, with the DS9490R USB adaptor, a TAI-8520
temperature sensor and a TAI-8540 humidity sensor.
I downloaded and installed 'digitemp', and this reads my sensors fine.

With owfs I am having some more trouble.
The RPMs don't want to install:
--------------------------
# rpm -ivh owfs-fs-2.5p0-1.i586.rpm owfs-libs-2.5p0-1.i586.rpm
error: Failed dependencies:
        libresmgr.so.0.9.8 is needed by owfs-fs-2.5p0-1.i586
        libusb-0.1.4 is needed by owfs-fs-2.5p0-1.i586
--------------------------
I am running a higher version of libusb (0.1.11-2.2)
My RPMs:
libusb-0.1.11-2.2
libusb-devel-0.1.11-2.2
fuse-devel-2.5.3-1.fc5
fuse-libs-2.5.3-1.fc5
fuse-2.5.3-1.fc5

So I decided to download the source RPM and recompile that:
--------------------------
Making all in php
make[3]: Entering directory `/root/.rpm/BUILD/owfs-2.5p0 /module/swig/php'
if /bin/sh ../../../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H
-I. -I. -I../../../src/include    -fexceptions -I.. -I../../../src/include
-I../../../module/owlib/src/include -D_FILE_OFFSET_BITS=64  -g -O2
-pthread -pthread -pthread -MT ow_wrap.lo -MD -MP -MF ".deps/ow_wrap.Tpo"
-c -o ow_wrap.lo ow_wrap.c; \
then mv -f ".deps/ow_wrap.Tpo" ".deps/ow_wrap.Plo"; else rm -f
".deps/ow_wrap.Tpo"; exit 1; fi
mkdir .libs
gcc -DHAVE_CONFIG_H -I. -I. -I../../../src/include -fexceptions -I..
-I../../../src/include -I../../../module/owlib/src/include
-D_FILE_OFFSET_BITS=64 -g -O2 -pthread -pthread -pthread -MT ow_wrap.lo
-MD -MP -MF .deps/ow_wrap.Tpo -c ow_wrap.c  -fPIC -DPIC -o
.libs/ow_wrap.o
ow_wrap.c:345:18: error: zend.h: No such file or directory
ow_wrap.c:346:22: error: zend_API.h: No such file or directory
ow_wrap.c:347:17: error: php.h: No such file or directory
ow_wrap.c: In function 'SWIG_SetPointerChar':
ow_wrap.c:414: warning: assignment makes pointer from integer without a cast
ow_wrap.c: At top level:
ow_wrap.c:420: error: expected ')' before '*' token
ow_wrap.c:522: error: expected ')' before '*' token
ow_wrap.c:546: error: expected ')' before '*' token
ow_wrap.c:609:21: error: php_ini.h: No such file or directory
ow_wrap.c:610:31: error: ext/standard/info.h: No such file or directory
In file included from ow_wrap.c:611:
php_OW.h:34: error: expected '=', ',', ';', 'asm' or '__attribute__'
before 'OW_module_entry'
php_OW.h:43: warning: data definition has no type or storage class
php_OW.h:43: warning: parameter names (without types) in function declaration
--------------------------
And many more errors after that.

So I decided to do download the tar.gz source code, and compile that.
This gives (as can be expected) the same result.
When I change the configuration, then the code compiles.
But the program does not run properly:
--------------------------
# ./configure --disable-php --disable-swig
# make install
# /opt/owfs/bin/owfs -u /mnt/1-wire/ --foreground --error_level=9
DEFAULT: Not a "character" device /mnt/1-wire/
DEFAULT: Not a "character" device /mnt/1-wire/
DEFAULT: Not a "character" device /mnt/1-wire/
DEFAULT: Not a "character" device /mnt/1-wire/
--------------------------
(and this keeps going)

Can someone help me out?
Am I missing something?

btw: I removed the default kernel module for the DS9490R, so that should
not be the problem in my opinion.

kind regards,

   Egon

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Owfs-developers mailing list
Owfs-developers <at> lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/owfs-developers

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Owfs-developers mailing list
Owfs-developers <at> lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/owfs-developers
Lorenz Drack | 6 Sep 15:54 2006
Picon

nslu2 pressure

Hi - I'm loving OWFS on the slug, and I  hope I'm not bothering too many people with this question: the 2x DS2406's for the TAI8570 AAG pressure sensor show up, but there is no TAI8570 subdirectory to read the pressure from. Could this be because the unslug ipkg version of owfs is 2.4p1-1? Is there anything I can do to get this working? I've read through the archives but no-one seems to have mentioned anything about this.
thanks very much
Lorenz
 
-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Owfs-developers mailing list
Owfs-developers <at> lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/owfs-developers
Paul Alfille | 6 Sep 21:35 2006
Picon

Re: nslu2 pressure

Sounds like we need a newer verions of OWFS for the slug. Can you do it?

Paul Alfille

On 9/6/06, Lorenz Drack <drack <at> bigfoot.com> wrote:
Hi - I'm loving OWFS on the slug, and I  hope I'm not bothering too many people with this question: the 2x DS2406's for the TAI8570 AAG pressure sensor show up, but there is no TAI8570 subdirectory to read the pressure from. Could this be because the unslug ipkg version of owfs is 2.4p1-1? Is there anything I can do to get this working? I've read through the archives but no-one seems to have mentioned anything about this.
thanks very much
Lorenz
 

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642

_______________________________________________
Owfs-developers mailing list
Owfs-developers <at> lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/owfs-developers



-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Owfs-developers mailing list
Owfs-developers <at> lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/owfs-developers
Christian Magnusson | 6 Sep 22:25 2006

Re: nslu2 pressure

 

Sorry for not building any new versions for nslu2 lately…

 

We got twins 6 months ago, and after that I have been very busy at work with many deadlines… and there haven’t been any spare time to do any daily builds.

I’m trying to compile a new version now… and hopefully it will be done before we are going to Crete tomorrow afternoon.

 

/Christian

 

 

 

 

Från: owfs-developers-bounces <at> lists.sourceforge.net [mailto:owfs-developers-bounces <at> lists.sourceforge.net] För Lorenz Drack
Skickat: den 6 september 2006 15:54
Till: owfs-developers <at> lists.sourceforge.net
Ämne: [Owfs-developers] nslu2 pressure

 

Hi - I'm loving OWFS on the slug, and I  hope I'm not bothering too many people with this question: the 2x DS2406's for the TAI8570 AAG pressure sensor show up, but there is no TAI8570 subdirectory to read the pressure from. Could this be because the unslug ipkg version of owfs is 2.4p1-1? Is there anything I can do to get this working? I've read through the archives but no-one seems to have mentioned anything about this.

thanks very much

Lorenz

 

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Owfs-developers mailing list
Owfs-developers <at> lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/owfs-developers
Christian Magnusson | 6 Sep 22:48 2006

Re: nslu2 pressure

 

I have compiled 2.5p0 now, and it’s located at http://owfs.sourceforge.net/nslu2/packages/ as usual.

I haven’t tried it myself yet, since I don’t have my NSLU2 at home at the moment.

 

/Christian

 

 

Från: owfs-developers-bounces <at> lists.sourceforge.net [mailto:owfs-developers-bounces <at> lists.sourceforge.net] För Christian Magnusson
Skickat: den 6 september 2006 22:25
Till: owfs-developers <at> lists.sourceforge.net
Ämne: Re: [Owfs-developers] nslu2 pressure

 

 

Sorry for not building any new versions for nslu2 lately…

 

We got twins 6 months ago, and after that I have been very busy at work with many deadlines… and there haven’t been any spare time to do any daily builds.

I’m trying to compile a new version now… and hopefully it will be done before we are going to Crete tomorrow afternoon.

 

/Christian

 

 

 

 

Från: owfs-developers-bounces <at> lists.sourceforge.net [mailto:owfs-developers-bounces <at> lists.sourceforge.net] För Lorenz Drack
Skickat: den 6 september 2006 15:54
Till: owfs-developers <at> lists.sourceforge.net
Ämne: [Owfs-developers] nslu2 pressure

 

Hi - I'm loving OWFS on the slug, and I  hope I'm not bothering too many people with this question: the 2x DS2406's for the TAI8570 AAG pressure sensor show up, but there is no TAI8570 subdirectory to read the pressure from. Could this be because the unslug ipkg version of owfs is 2.4p1-1? Is there anything I can do to get this working? I've read through the archives but no-one seems to have mentioned anything about this.

thanks very much

Lorenz

 

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Owfs-developers mailing list
Owfs-developers <at> lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/owfs-developers
Paul Alfille | 8 Sep 22:10 2006
Picon

Fwd: owfs pressure



---------- Forwarded message ----------
From: Lorenz Drack <drack <at> bigfoot.com>
Date: Sep 8, 2006 12:31 PM
Subject: RE: owfs pressure
To: Paul Alfille <paul.alfille <at> gmail.com>

Hi Paul - I've noticed an update in the nslu package directory 2.5p0-1 - I hope I haven't stuffed things up by upgrading my owfs before you'd finished - but now the 1-wire filesystem doesn't mount anymore, just sits there at the fuse.o line when I try to start it.  Do I perhaps need to remove the old version or something along those lines?
thanks very much
Lorenz
-----Original Message-----
From: Paul Alfille [mailto: paul.alfille <at> gmail.com]
Sent: Wednesday, 6 September 2006 11:43 PM
To: Lorenz Drack
Subject: Re: owfs pressure

I guess I'll have to write a routine that generates the memory contents.

Give me a day.

Paul

On 9/6/06, Lorenz Drack <drack <at> bigfoot.com> wrote:
Hi Paul - I'm using owfs on my SLUG and everything is grand! Love the software. One problem though - the 2 x DS2406's that belong to the AAG pressure sensor show up, but neither have the T AI8570 directory in which the pressure value is supposed to live. Would you have any suggestions on how I could get this working? The version of owfs is the current distro for the slug
thanks very much
Lorenz

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Owfs-developers mailing list
Owfs-developers <at> lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/owfs-developers
Paul Alfille | 9 Sep 21:23 2006
Picon

Fwd: Problem with owfs / fuse (?)



---------- Forwarded message ----------
From: Philipp Haeuser <funkbird <at> web.de>
Date: Sep 9, 2006 2:12 PM
Subject: Problem with owfs / fuse (?)
To: palfille <at> earthlink.net


Hi Paul,

I installed OWFS on my Debian Sarge Linux box, I'm using
1-wire devices to monitor my central heating at home. I want
to move to owfs for reading the values, as the present
solution is not as stable as it should be.

I've got the owfs-2.5p0 from sourceforge and fuse-2.5.3 .

The owserver and the owhttpd run just fine, only the owfs
does not run, I get the  following error message
multiple times:

DEFAULT: Not a "character" device /root/1wire

This is the owfs startup script I use:

#!/bin/sh
PATH=$PATH:/opt/owfs/bin
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/owfs/lib
# already loaded by debian: insmod /root/fuse-2.5.3/kernel/fuse.o
rmdir /root/1wire
mkdir /root/1wire 2> /dev/null
/opt/owfs/bin/owserver -C -d "DS9097U" /dev/ttyS1 -p 3333
/opt/owfs/bin/owhttpd -s 3333 -p 3001
/opt/owfs/bin/owfs -s 3333 /root/1wire --error_level 4

It all works fine, I can use the owhttpd, only owfs throws
the "Not a character device" error message.


Is there anything obvious wrong with my script? It might be a
problem with fuse - as I do not have a clue what's
actually wrong, maybe you've solved that issue
before?

Any help is appreciated! Feel free to forward this
message to any mailing list (CC: to me, please).

Regards
Philipp

P.S.: In case you're interested, these are the graphs
that I generate:
http://sued40.dyndns.org/temperature-heizung/


-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Owfs-developers mailing list
Owfs-developers <at> lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/owfs-developers

Gmane