jason wilson | 15 Jan 04:36 2006
Picon

[sshfs] sshfs + eclipse workspace problem


I am trying to use sshfs to mount an eclipse workspace remotely. I can mount 
the filesystem okay and everything appears to be in tact. However, in 
eclipse when I try to add the project, it finds the directory 
(/mnt/remote/foo) but fails to recurse down and find the associated java 
files.

Example:

Suppose directory /mnt/remote/foo/bar/baz/  contains 3 files One.java, 
Two.java, Three.java

When I try to automatically "discover" the project, Eclipse fails to find 
any files under the directory /foo/bar/baz, but when I go to 
File->Open->File I can manually search down the directory structure and open 
the file(s).

I've tried enabling various sshfs mounting options but nothing has seemed to 
work.  Out of curiosity I tried the abandoned shfsmount and it didn't have 
this problem, but I found it too unstable to be productive.

Next I tried starting from scratch and creating a new empty project over the 
sshfs mount point. Everything appeared to be going normally, then all of the 
sudden Eclipse lost the handle to "SomeFile.java", warning that the file had 
been removed.  But in a shell I went down into: /mnt/virtual/someproject/" 
and the file SomeFile.java still existed.

Any ideas/suggestions? Is this an eclipse problem or an sshfs problem?

Thanks,
(Continue reading)

Alex Haan | 15 Jan 23:35 2006
Picon

[sshfs] symbolic link

Hello,

I've been using forms of shfs for some time now. Now I have fuse-sshfs installed.
I always found it very handy not to need ftp or something else to be able to access a remote system 
easily.

Today i was working on a project using subversion. I wanted to export the project to a sshfs-mointed 
point. The project included symlinks and upon exporting i got some errors.
First i thought it had to do with some program used for subversion, but soon i figured out creating 
a symlink could have some issues.

Example:

mountpoint: ~/mnt/remote
mountpath: user <at> remoteaddr:path

when i create a symlink like: ln -sf ~/mnt/remote/source ~/mnt/remote/target I can get several errors:
- File or Directory does not exist (on targetfile)
- Operation not permitted
- once i got something about too many symlink levels (which could be caused by the subversion 
related program)

sshclient:  OpenSSH_4.2p1, OpenSSL 0.9.7f 22 Mar 2005    (FC4)
sshserver:  OpenSSH_4.2p1 FreeBSD-20050903, OpenSSL 0.9.7e-p1 25 Oct 2004 (with HPN patch)

Copying a whole directory, including symlinks, over to the remote point doesn't cause any problems.

I don't really need the symlinks, so I took them out of the repository. But I'm wondering whether 
this problem is known or that it's perhaps a local problem. Anyway I know what can cause a problem 
now and will work around that. Hopefully this is of some use to you.
(Continue reading)


Gmane