Abrolag | 30 Mar 01:24 2014

display svg icons and thumbnails

I've just done an install on a new machine and have completely forgotten how to
enable this - unfortunately it's one of the few things I didn't put in my
notes :(

Anyone know how to do it?


Will J Godfrey
Say you have a poem and I have a tune.
Exchange them and we can both have a poem, a tune, and a song.

gmp.samk-01 | 31 Oct 10:05 2013

Re: ROX-Filer Copy Command to CIFS

On 18 October 2013 Thomas Leonard - talex5 <at> g... wrote
> Sure, just submit a (Git) patch or pull request.
I am not in a position to do this.  Perhaps you, or other
long-standing ROX developers might be better placed to implement the

The mailing list contains the following from july/August 2012.

It appears the symptoms are similar to those observed when using CIFS.
 A patch was offered at that time, however it is unlear whether it was


Android is increasing in popularity, but the open development platform that
developers love is also attractive to malware creators. Download this white
paper to learn more about secure code signing practices that can help keep
Android apps secure.
gmp.samk-01 | 16 Oct 16:28 2013

ROX-Filer Copy Command to CIFS

I'm working with the lead developer of antiX.  Since 2007 all its
releases have shipped with ROX-Filer and Pinboard as the distro

Hoping to find help with a bogus ROX-Filer error message that can be
obtained when copying files to a cifs (Samba) share.  The error says
the copy failed, but in fact completes successfully.

antiX also ships with other file managers, SpaceFM and Midnight
Commander (mc).  The error message is not generated when using these
or the standard CLI "cp" command.

The problem seems to be caused by the way ROX-Filer copies files and
dirs using the command "cp -p".

There is a workaround mentioned in the Troubleshooting section of this
ROX reference guide.  Look in the sub-section "Errors when copying to
Windows partitions"
Unfortunately it cannot be used when mounting cifs (Samba) shares as
the "quiet" option is invalid.

Is there a way to force the "cp" rather than "cp -p"?

Alternatively, could an option be added to ROX-Filer-->Options-->Drag
and Drop-->(or similar) to make parameters to the "cp" command user

October Webinars: Code for Performance
(Continue reading)

Abrolag | 24 Sep 21:54 2013

DevTray borked :(

This has been a bit flaky for a while now producing 'Insertion Error' when
trying to open CDs but nevertheless succeeding eventually, and as I don't have
much use for CDs these days I've not bothered with it.

However, with the latest version of debian testing it has failed completely.
(This is on the computer at work - I haven't done the latest upgrade at home)

Also, I can't file a bug report because the error 'save' dialogue doesn't work

Looking at the on-screen report there is something about HAL and udev not
getting a reply in time.

As a temporary measure I can get round this using pmount and pumount but I
really would like a solution that plays nice with ROX. If I use pmount to
access a USB stick I can't then unmount via the ROX dialogue .

I know there hasn't been any development for a long time now, but I'd be very
grateful if someone could have a look at this.


Will J Godfrey
Say you have a poem and I have a tune.
Exchange them and we can both have a poem, a tune, and a song.

October Webinars: Code for Performance
Free Intel webinars can help you accelerate application performance.
Explore tips for MPI, OpenMP, advanced profiling, and more. Get the most from 
(Continue reading)

Mike Hobbs | 18 Apr 16:18 2013

rox on ubuntu 12.10

Installed rox and it runs, but...

1. it can only be started from the command line
   (e.g. rox -n &)
   I've tried numerous suggestions as to how to launch it from
   the Unity launcher or gnome desktop launcher, or a backdrop
   icon. None work.

2. as rox-filer is running as a detached process it produces
   (rox:14926): Gtk-WARNING **: GtkSpinButton: setting an adjustment 
with non-zero page size is deprecated

3. curiously, when running rox from sudo su root session
   it is not necessary to use the "-n" option on the
   command line, but when running as another user, I have
   to use "rox -n" otherwise nothing happens.

4. Ideally, I'd have rox-filer as the default file manager
   but the procedure someone published for changing the
   default filer from nautilus to some other filer didn't
   work for rox-filer.

5. I found the installation pages on the web site very
   confusing and could not get them to work. In the end
   I used "apt-get install rox-filer" and it worked. Perhaps
   its time to update the web pages, which iirc mentioned
   Rox-All 1.3 and when I followed the links to download
   it lead me to Archive 2.3 (and not Rox-All).

Any answers/pointers would be welcome
(Continue reading)

minhsien0330 | 8 Feb 14:44 2013

Automatically refresh mounting state of the device icons on pinboard?

Dear all:
I drag /media/sdb1 to pinboard, the icon (/media/sdb1) on pinboard has a "small ball" on upper left corner which means the device /media/sdb1 is mounted.

If I umount /media/sdb1, the "small ball" of icon on pinboard will not disappear unless I move the mouse over the icon.

Do you know how to make the device icon on pinboard automatically refresh it's mounting state?

Thanks a lot~

Best Regards,
Free Next-Gen Firewall Hardware Offer
Buy your Sophos next-gen firewall before the end March 2013 
and get the hardware for free! Learn more.
rox-users mailing list
rox-users <at> lists.sourceforge.net
Dennis Nezic | 31 Jan 19:31 2013

Better "select by name" behavior

So, currently (rox-2.10), when you MINI_SELECT_BY_NAME (. command), it
defaults to the "*." glob -- i.e. it assumes we want to select by a
certain file extension. I found that I usually wasn't searching by file
extension, but rather by keywords within filenames, and often found
myself having to backspace. So, I think it would be better to not have
that initial default glob.

Also, when matches were found, although they were selected, the window
wouldn't scroll to them (if they weren't visible -- ie. in a folder
with many files.) I think the window should jump to the first match,
much like the current MINI_PATH does. This little patch here does
something like that, although I'm not sure if it's the best way :P --
it will move the window and the non-highlighted-selected entry down one
each time a new glob is matched.
Attachment (better-select-by-name.patch): application/octet-stream, 985 bytes
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
rox-users mailing list
rox-users <at> lists.sourceforge.net
Jim Lesurf | 16 Jan 13:34 2013

ROXtone, etc


I've just added another rox application (ROXtone) to my software page at

This follows on from ROXscope, so I can now use my machines as a combined
signal source and scope/fft-analyser for audio tests.

I'm wondering if anyone might like to mention/link the applications or page
on the main ROX pages that list applications, etc.




Electronics  http://www.st-and.ac.uk/~www_pa/Scots_Guide/intro/electron.htm
Armstrong Audio  http://www.audiomisc.co.uk/Armstrong/armstrong.html
Audio Misc  http://www.audiomisc.co.uk/index.html

Master Java SE, Java EE, Eclipse, Spring, Hibernate, JavaScript, jQuery
and much more. Keep your Java skills current with LearnJavaNow -
200+ hours of step-by-step video tutorials by Java experts.
SALE $49.99 this month only -- learn more at:
Thomas Leonard | 30 Dec 14:10 2012

ROX web-site hacked

I got an email today from Google to say that the ROX web-site
contained spammy links. On investigation, I found some suspicious
files on the server (a .htaccess which redirected things to
"image.php", which contained a load of obfuscated PHP). The oldest
ctime was Nov 11, 2012.

This isn't very surprising; Drupal has regular security
vulnerabilities and I don't have time at the moment to keep it
properly patched. I have therefore exported the whole site to static
HTML (using httrack). I also moved it back to sourceforge.net since,
being static, database performance is no longer an issue:


There should be no risk of anyone having installed malicious software
from the site, since 0install always ensures the GPG signatures are
correct when downloading software (and the signing key is not on the

I will probably move ROX-Filer over to github at some point, along
with anything else that needs updating in the future.

Hopefully that's the end of it, but let me know if you spot anything suspicious.


Dr Thomas Leonard        http://0install.net/
GPG: 9242 9807 C985 3C07 44A6  8B9A AE07 8280 59A5 3CC1
GPG: DA98 25AE CAD0 8975 7CDA  BD8E 0713 3F96 CA74 D8BA

Master Visual Studio, SharePoint, SQL, ASP.NET, C# 2012, HTML5, CSS,
MVC, Windows 8 Apps, JavaScript and much more. Keep your skills current
with LearnDevNow - 3,200 step-by-step video tutorials by Microsoft
MVPs and experts. ON SALE this month only -- learn more at:
Abrolag | 21 Nov 23:19 2012

MIME issue

A while ago the arduino project changed from using the .pde extension to .ino

For some reason, ven though the file content is identical ROX thinks .ino is a
text file so I can't get it to run the arduino app when clicking on such a file
without it then deciding to attempt to run all text files through this app.

Any suggestions as to how I can get round this.


Will J Godfrey
Say you have a poem and I have a tune.
Exchange them and we can both have a poem, a tune, and a song.

Monitor your physical, virtual and cloud infrastructure from a single
web console. Get in-depth insight into apps, servers, databases, vmware,
SAP, cloud infrastructure, etc. Download 30-day Free Trial.
Pricing starts from $795 for 25 servers or applications!
thilo | 21 Oct 22:12 2012

ROX-Filer, NFS and .DirIcon problem

Hello everyone,

I just encountered the following problem: after copying several
images (each named ".DirIcon") into different directories on a
NFS mount, my ROX-Filer (2.11) Window does, as expected, show
some of them instead of the default folder icon, but not all.

I discovered that for ROX-Filer to show the new icons, both the
directory (on the NFS mount) AND the corresponding .DirIcon
must be owned by myself. This is a bit surprising, since both
directories and .DirIcons are world readable.
This can be reproduced: as soon as the directory or the
.DirIcon are not owned by myself, the Filer displays the
default folder icon.

I copied the directories onto a local ext4 filesystem and
played with the ownerships. Everything's allright, ROX Filer
always shows the .DirIcon images.

I am not at all sure that this would be a ROX Filer problem,
may also be related to NFS or something completely different.
However, as both the directory and the .DirIcon are readable,
the filer should IMO display the new icon.

Any hints?


Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today: