M Nagaraj | 25 May 14:37 2016

riak cs performance question


I am quite new to RIAK-*. I have setup riak cs on a single server (for
evaluation purposes) with adequate RAM, CPU and high performance storage. I
am using Cosbench to benchmark RIAK-CS using the S3 proxy connection.
Cosbench is also running on the same server (the reasons being I wanted to
eliminate the effect of network on performance).

I have tried different workloads (100% reads, 80:20 read write mix, number
of objects (20-20000), size of objects (4K-64K)). My observation has been
that I have not managed to push the throughput to beyond 2.5Kops - the best
case being 100% reads and about 128 objects and 128 cosbench worker threads.
With 20% writes the number comes down to less than 1000.

The CPU is largely idle, plenty of RAM left (order of GB). Storage is
capable of 300K+ IOPS but hardly utilised.

Coming to my question: does this represent the limit of performance of a
*single* riak-cs node. I notice that the average response time is in the
order of 60ms.

Lastly, has anyone compared S3 with RIAK-CS?


View this message in context: http://riak-users.197444.n3.nabble.com/riak-cs-performance-question-tp4034341.html
Sent from the Riak Users mailing list archive at Nabble.com.
(Continue reading)

Richard Jonas | 25 May 12:28 2016



most of the examples I can see that riak erlang client processes cannot be shared with multiple processes. Is it safe if more processes use the same riak connection? So in other words: is riak erlang client thread-safe?


Richard Jonas
Erlang Solutions Hungary Kft

  Riverpark Office K.32
  Közraktár street 32. 3/1.
  1093 Budapest
riak-users mailing list
riak-users <at> lists.basho.com
Anil Chandgude(HO | 24 May 16:50 2016

copy solr indexes

Hi Riak-users
 I want to copy solr indexes directly from my one machine to another.  So I can use it on destination machine. I have all setup of riak on both machine.
Please suggest some solution 

Thanks and regards,
Anil C

riak-users mailing list
riak-users <at> lists.basho.com
Vikram Lalit | 24 May 16:34 2016

Riak Cluster Behavior - Clarification

Hi - I'd appreciate if someone can opine on the below behavior of Riak that I am observing... is that expected, or something wrong in my set-up / understanding?

To summarize, I have a 3-node Riak cluster (separate EC2 AWS instances) with a separate chat server connecting to them. When I write data on the Riak nodes, the process is successful and I can read all data correctly. However, as part of my testing, if I deliberately bring down one node (and then remove it from the cluster using riak-admin cluster force-remove / plan / commit), the client API is not able to fetch all the written data. In fact, there is an alternation of success and failure which happens rather randomly.

My initial suspicion was that it would be happening only during the time the rebalancing is occurring (i.e. riak-admin ring-status is not fully settled) but I've seen this sporadic behavior post the same too.

Does this have to do with the n and r values for the cluster and given that 1 node is down, the cluster does not succeed in returning results reliably? Also, does this mean that during the time a cluster is being rebalanced (even incl. addition of new nodes), the results could be arbitrary - that doesn't sound correct to me?

Appreciate if someone can throw some light here? Also, the HTTP API calls to retrieve and set the n / r / w values for a specific bucket - couldn't locate the same!

Thanks much!

riak-users mailing list
riak-users <at> lists.basho.com
Robert Latko | 21 May 21:01 2016

Riak install on instance with multiple OTP's

Hi all,

Quick question:

I have an instance with OTP18 and I want to make it a Riak Node. I 
DL/install  the OTP16 patch 8 for Riak 2.1.4.  How then do I use make 
rel to use OTP16 instead of the default OTP18??

Thanks in advance.


Alex De la rosa | 21 May 20:41 2016

Questions about installing Stanchion for Riak CS

Hi there,

I'm creating a Riak CS cluster and I got some questions about the following sentence from the documentation:

Riak KV and Riak CS must be installed on each node in your cluster. Stanchion, however, needs to be installed on only one node.

Is this statement saying that only 1 node can have Stanchion? Or can it be placed in more servers?.... like Riak KV and Riak CS must be in 5 out of 5 nodes but Stanchion can be in 1 to 5 out of 5 nodes?

If is referring that ONLY 1 out of 5 nodes can have Stanchion and the other 4 nodes are not allowed to have it installed, what happens if the "master" node that has Stanchion crashes?

Thanks and Best Regards,
riak-users mailing list
riak-users <at> lists.basho.com
Alexander Sicular | 21 May 03:56 2016

Riak Recap, May 20th, 2016

Hello All,

Just in time for the weekend we bring you a rundown of announcements, jobs, some code and, of course, the mailing list review.

As always, we want to hear from you. If you’re working on or speaking about something Riak related and would like to be highlighted - send me a note! Let me know what you’re up to and I’ll get your talk or blog post in the next Riak Recap.

## Announcements

  • Two client library updates this week, PHP and .NET. Check em out:

    • Riak PHP Client v 3.1.0 adds access to Riak TS via HTTP [0]

    • Riak .NET Client v 2.3.0 brings Riak TS and external load balancing support [1]

  • A Riak TS AMI for AWS is now available [2].

## Community Code and Walkthroughs

  • Craig Vitter put some code out accompanying his talk last week in NYC on Riak TS. The code walks through using Riak TS with python and jupyter [3].

  • Seema Jethani also drops some code with a talk she gave this week at Data By the Bay in San Francisco on working with time series data from the London Air Quality Network in Riak TS and other projects [4].

  • Stephen Etheridge shows us how to get started with Spark and Riak TS [5].

  • Susan Lee introduces us to Riak TS using Stephens code [6].

##Community Events

  • Basho Engineer Jason Voegele, <at> jvoegele, will be giving a talk at LambdaConf in Boulder, CO entitled “Dialyzer: Optimistic Type Checking for Erlang and Elixir” [7].

## Jobs at Basho

Interested in working on distributed computing related problems or helping our community with theirs? Perhaps these open positions at Basho may be of interest:

  • Client Services Engineer (USA) [8].

  • Developer Advocate (London and US) [9].

Basho is remote friendly!

## Recently Answered

  • Alex gets help modifying the default Solr schema [10].

  • Luke goes above and beyond helping Sanket debug his AWS environment in order to get pre-commit hooks working [11]. If you’re looking to do something similar, instructions are here [12].

  • Alex and I have a conversation about Solr schema design. To store or not to store. [13].

  • Luke confirms Basho is working on security and drop/truncate table features in upcoming releases [14].

  • Daniel helps David grok deleting an object in Riak [15]. Welcome aboard, David!

  • Kaz helps a different David by pointing out two key Riak KV configuration options when setting up KV for Riak CS [16].

  • Vitaly helps Alex with Solr indexing [17] and Drew highlights specific sections of the default Solr schema shipped with Riak KV [18].

  • Fred points out to Alex that although you can query Solr directly, there are considerations [19]. John queries Solr directly after caching a copy of the cluster plan every so often [20].

  • Vitaly shows Alex how to configure Solr for case insensitive indexing [21].

  • Magnus confirms that Basho is working on making Riak compatible with Erlang OTP 18 [22] and highlights a github issue and pull request that help Humberto with his specific compilation issue on OSX.

  • Luke confirms to one Outback Dingo that Riak TS is not supported on FreeBSD and support for Riak KV on FreeBSD will be discontinued [23].

  • Serena is seeking out a Debian Jesse package. Brett assures us a package is on the way [24].

## Open Discussions

  • Vladimir asks the list for help with the following warning “perflists do not satisfy the n_val” [25].

  • Alex is looking for advice regarding whether or not Riak TS would be better suited in certain use cases over Riak KV for his social network project [26].

  • Michael is looking for some guidance on properly sizing a Riak S2 cluster [27].

  • Psterk is looking for help on using hadoops’s distcpy to copy files from Riak S2 to hadoop [28][29].

  • The conversation around Riak DT [30] continues with Sargun offering to contribute some enhancements [31]. In case you’re wondering, yes, contributions will be highlighted.

  • Johnny is looking for help working with credentials in Riak S2 [32].

  • A number of folks contribute to a great thread helping Alex on his question about write performance when writing sequential alpha-numeric keys [33]. There is a sidebar on CRDT’s vs write_once buckets in there as well [34].

Have a great weekend,

-Alexander Sicular

Solution Architect, Basho

<at> siculars

[0] https://github.com/basho/riak-php-client/releases/tag/v3.1.0

[1] https://github.com/basho/riak-dotnet-client/blob/master/RELNOTES.md

[2] http://lists.basho.com/pipermail/riak-users_lists.basho.com/2016-May/018401.html

[3] https://github.com/cvitter/Easy-Time-Series-Analysis-with-Riak-TS

[4] https://github.com/svjethani/airquality/blob/master/AirQuality1Q2016.ipynb

[5] https://github.com/datalemming/rts12-sc-demo

[6] https://www.youtube.com/watch?v=qZ-T4eEdC_g

[7] http://lambdaconf.us/#schedule

[8] http://bashojobs.theresumator.com/apply/0CTNKU/Client-Services-Engineer-Remote

[9] http://bashojobs.theresumator.com/apply/nVY7Ea/Developer-Advocate-EMEA

[10] http://lists.basho.com/pipermail/riak-users_lists.basho.com/2016-May/018376.html

[11] http://lists.basho.com/pipermail/riak-users_lists.basho.com/2016-May/018383.html

[12] http://lists.basho.com/pipermail/riak-users_lists.basho.com/2016-May/018447.html

[13] http://lists.basho.com/pipermail/riak-users_lists.basho.com/2016-May/018388.html

[14] http://lists.basho.com/pipermail/riak-users_lists.basho.com/2016-May/018405.html

[15] http://lists.basho.com/pipermail/riak-users_lists.basho.com/2016-May/018399.html

[16] http://lists.basho.com/pipermail/riak-users_lists.basho.com/2016-May/018402.html

[17] http://lists.basho.com/pipermail/riak-users_lists.basho.com/2016-May/018407.html

[18] http://lists.basho.com/pipermail/riak-users_lists.basho.com/2016-May/018414.html

[19] http://lists.basho.com/pipermail/riak-users_lists.basho.com/2016-May/018431.html

[20] http://lists.basho.com/pipermail/riak-users_lists.basho.com/2016-May/018426.html

[21] http://lists.basho.com/pipermail/riak-users_lists.basho.com/2016-May/018422.html

[22] http://lists.basho.com/pipermail/riak-users_lists.basho.com/2016-May/018429.html

[23] http://lists.basho.com/pipermail/riak-users_lists.basho.com/2016-May/018439.html

[24] http://lists.basho.com/pipermail/riak-users_lists.basho.com/2016-May/018451.html

[25] http://lists.basho.com/pipermail/riak-users_lists.basho.com/2016-May/018375.html

[26] http://lists.basho.com/pipermail/riak-users_lists.basho.com/2016-April/018279.html

[27] http://lists.basho.com/pipermail/riak-users_lists.basho.com/2016-March/018242.html

[28] http://lists.basho.com/pipermail/riak-users_lists.basho.com/2016-April/018321.html

[29] http://lists.basho.com/pipermail/riak-users_lists.basho.com/2016-April/018322.html

[30] https://github.com/basho/riak_dt/

[31] http://lists.basho.com/pipermail/riak-users_lists.basho.com/2016-May/018441.html

[32] http://lists.basho.com/pipermail/riak-users_lists.basho.com/2016-May/018353.html

[33] http://lists.basho.com/pipermail/riak-users_lists.basho.com/2016-May/018354.html

[34] http://lists.basho.com/pipermail/riak-users_lists.basho.com/2016-May/018356.html

riak-users mailing list
riak-users <at> lists.basho.com
Alex De la rosa | 18 May 19:07 2016

Ranking search results by relevancy

Hi all,

I would like to perform a search on Riak/Solr of people given an input containing its full name (or part of it), like when searching for members in Facebook's search bar.

search input [ alex garcia ]

results = client.fulltext_search('people', 'firstname_register:*alex* OR lastname_register:*garcia*')

this would give me members like:

alex garcia
alexis garcia
alex fernandez
jose garcia

Is there any way to get these results ranked/ordered by the most precise search? "alex garcia" would be the most relevant because matches equally to the search input... "alexis garcia" may come second as even not an exact match is very similar pattern, the other two would come after as they match only 1 of the 2 search parameters.

Would it be convenient to index also fullname_register:alex garcia in order to find exact matches too?

Can it be done all at once in just 1 search query? or should I compile results from 3 queries?

result_1 = client.fulltext_search('people', 'fullname_register:alex garcia')
result_2 = client.fulltext_search('people', 'firstname_register:*alex* AND lastname_register:*garcia*')
result_3 = client.fulltext_search('people', 'firstname_register:*alex* OR lastname_register:*garcia*')

Thanks and Best Regards,
riak-users mailing list
riak-users <at> lists.basho.com
Serena Lorenzini | 18 May 09:52 2016

riak for debian jessie

I've noticed that there is not any jessie-related package for riak (I am
reading the list here https://packagecloud.io/basho/riak). Is this just
a matter of time or a manifestation of an intention to not support riak
in a debian environment for the current and future releases?

If I missed some important notes about jessie support please accept my

Best regards

Serena Lorenzini


Serena Lorenzini, PhD - serena AT biodec dot com
BioDec Srl, Via Calzavecchio 20/2, 40033 Casalecchio di Reno (BO), Italy
Phone: (+39)-051-0548263 - Fax: (+39)-051-7459582 - http://www.biodec.com
Luke Bakken | 16 May 16:48 2016

Re: Precommit hook function - no error log - how to debug?

Hi Sanket,

Thanks for providing that information, this is the first time that the
"write_once" bucket type property was mentioned.

If you set the precommit hook on a different bucket type where there
are *no other* custom bucket type properties set, does the precommit
hook run successfully?

Luke Bakken
lbakken <at> basho.com

On Mon, May 16, 2016 at 7:17 AM, Sanket Agrawal
<sanket.agrawal <at> gmail.com> wrote:
> Hi Luke,
> More on the precommit hook debugging I just did - I might have a handle on
> what the problem is. I took a cluster-info dump for all the nodes in the
> cluster. In the dump, precommit is set to [] for all the buckets in the
> cluster. The reason for that seems to be that the bucket type with
> "write-once" property where precommit hook is set, is not in the cluster
> somehow!
> The bucket type name is "test_kv_wo". Let us grep for it in cluster_info.txt
> - it doesn't show up at all (another bucket type "test_kv" shows up
> instead):
>> $ grep test_kv cluster_info.txt | sort -u
>>     [[{bucket,&lt;&lt;"test_kv">>}|
>>         {name,&lt;&lt;"test_kv">>},
> Now, let us verify we can get the props for the bucket type fine from curl:
>> $ curl localhost:8098/types/test_kv_wo/buckets/uuid_log/props:
>> {"props":{"name":"uuid_log","active":true,"allow_mult":true,"basic_quorum":false,"big_vclock":50,"chash_keyfun":{"mod":"riak_core_util","fun":"chash_std_keyfun"},"claimant":"riak1 <at>","dvv_enabled":true,"dw":"quorum","last_write_wins":false,"linkfun":{"mod":"riak_kv_wm_link_walker","fun":"mapreduce_linkfun"},"n_val":3,"name":"uuid_log","notfound_ok":true,"old_vclock":86400,"postcommit":[],"pr":0,"precommit":[{"mod":"rtriggers","fun":"pre_uuid"}],"pw":0,"r":"quorum","rw":"quorum","small_vclock":50,"w":"quorum","write_once":true,"young_vclock":20}}
> So, the problem might be missing bucket types in the cluster since they
> don't show up in cluster-info at all? The same thing happens with LWW bucket
> type that I created, test_kv_lww. It doesn't show up either. CRDT bucket
> types show up fine.
Humberto Rodríguez Avila | 16 May 00:38 2016

Compilation issues with OTP 18.3: "Failed to load erlang_js_drv.so"

Hello, I have been trying to compile erlang_js with OTP 18.3, but allways I get this message "Failed to load erlang_js_drv.so". I tried in Ubunto 14.0.04 and OSX 10.11.4.

Here you can find the full log of my error: https://gist.github.com/rhumbertgz/ee0bf432edfa89ffa0a47405f3250fcd

Any suggestion?

Thanks in advance
riak-users mailing list
riak-users <at> lists.basho.com