Tomoaki Murakami | 1 Mar 16:10 2004
Picon

how to wait for playing

Hello.

I'm using ecasound for multi track recording.
I'm begginer but I think this tool is very cool.

Well, I have a question.
I want to run chains like below:

-------------------------------------------------
Please watch with fixed font.

* : playing
- : waiting or finished

position (sec.)  0   10   20   30   40   50   60
                 |    |    |    |    |    |    |
chain 1 (1.wav)  |*****************************|
                 |    |    |    |    |    |    |
chain 2 (2.wav)  |----*****--------------------|
                 |    |    |    |    |    |    |
chain 3 (3.wav)  |------------**********-------|

-------------------------------------------------

(1) Ecasound starts playing 1.wav.
(2) When 10 seconds has been passed from (1), 
    ecasound starts playing 2.wav.
(3) When 25 seconds has been passed from (1), 
    ecasound starts playing 3.wav.

(Continue reading)

Jan Weil | 1 Mar 16:35 2004
Picon

Re: how to wait for playing

On Mon, 2004-03-01 at 16:10, Tomoaki Murakami wrote:
> Hello.

Hi!

[snip ascii art]

> 
> (1) Ecasound starts playing 1.wav.
> (2) When 10 seconds has been passed from (1), 
>     ecasound starts playing 2.wav.
> (3) When 25 seconds has been passed from (1), 
>     ecasound starts playing 3.wav.
> 
> How do I operate like above by ecasound?

Use ewf files. 

--8<-- 2.ewf --8<--
source = 2.wav
offset = 10.0
length = 10.0
--8<-----------8<--

--8<-- 3.ewf --8<--
source = 3.wav
offset = 25.0
length = 20.0
--8<-----------8<--

(Continue reading)

Ryan*PC Gibson | 2 Mar 12:13 2004
Picon

Compiling under cygwin

Hello:

    I am having problems compiling ecasound under cygwin.  I have updated my cygwin/win2k installation with the latest version of everything (gcc 3.3.1).  I have tried compiling ecasound-2.2.1, ecasound-2.3.0, ecasound-2.3.1, and ecasound-2.3.2 on two different PCs and I still get the same error.

make[2]: Entering directory `/home/ryan.gibson/ecasound-2.3.2/ecasound'
c++ -DHAVE_CONFIG_H -I. -I. -I.. -I../readline-4.0 -I. -I.. -I../libecasound -I../kvutils    -g -O2 -D_REENTRANT -D_REENTRANT -ffast-math -fstrict-aliasing -funroll-loops -DNDEBUG -DENABLE_DBC -c ecasound.cpp
ecasound.cpp: In function `void* ecasound_watchdog_thread(void*)':
ecasound.cpp:489: error: `sigwait' undeclared (first use this function)
ecasound.cpp:489: error: (Each undeclared identifier is reported only once for each function it appears in.)

    ...any ideas?

    -- Ryan*PC Gibson

--
--- "Ryan*PC Gibson <ryan.gibson <at> shazamteam.com>" ---------------------- ----------------- Development & Integration Manager -- 02074713462 ----- ------ Shazam Entertainment -- "If it sounds good, tag it!" (tm) ------- This e-mail and its contents are strictly private and confidential. It must not be disclosed, distributed or copied without our prior consent. If you have received this transmission in error, please notify Shazam Entertainment immediately on: 020 7471 3440 and then delete it from your system. Please note that the information contained herein shall additionally constitute Confidential Information for the purposes of any NDA between the recipient/s and Shazam Entertainment.
Unknown | 2 Mar 16:12 2004

Re: how to wait for playing

Hi, Jan!

Thank you!
I achieved it.

PS
My figure's spaces have been trimmed...
But you understand me, DOMO-ARIGATO!

--
To unsubscribe send message 'unsubscribe' in the body of the
message to <ecasound-list-request <at> wakkanet.fi>.

Ryan*PC Gibson | 2 Mar 19:55 2004
Picon

Re: Compiling under cygwin

I answered my own question (with a little help from a developer here).  It looks like the config.h was defining "HAVE_SIGWAIT" even though it should not.  I commented out the following from config.h

/* Define if you have the sigwait function.  */
/* #define HAVE_SIGWAIT 1 */

    Another error appeared, but it had to do with pyecasound which I dont need so I also disabled it with --disable-pyecasound

So the final steps were:
% tar -xzvf /tmp/ecasound-2.3.2.tar.gz
% cd ecasound-2.3.2
% ./configure --disable-pyecasound
Edit config.h to comment out HAVE_SIGWAIT
% make
% make install


    Perhaps this post will help someone, someday, somewhere :)

    -- Ryan*PC

Ryan*PC Gibson wrote:
Hello:

    I am having problems compiling ecasound under cygwin.  I have updated my cygwin/win2k installation with the latest version of everything (gcc 3.3.1).  I have tried compiling ecasound-2.2.1, ecasound-2.3.0, ecasound-2.3.1, and ecasound-2.3.2 on two different PCs and I still get the same error.

make[2]: Entering directory `/home/ryan.gibson/ecasound-2.3.2/ecasound'
c++ -DHAVE_CONFIG_H -I. -I. -I.. -I../readline-4.0 -I. -I.. -I../libecasound -I../kvutils    -g -O2 -D_REENTRANT -D_REENTRANT -ffast-math -fstrict-aliasing -funroll-loops -DNDEBUG -DENABLE_DBC -c ecasound.cpp
ecasound.cpp: In function `void* ecasound_watchdog_thread(void*)':
ecasound.cpp:489: error: `sigwait' undeclared (first use this function)
ecasound.cpp:489: error: (Each undeclared identifier is reported only once for each function it appears in.)

    ...any ideas?

--
--- "Ryan*PC Gibson <ryan.gibson <at> shazamteam.com>" ---------------------- ----------------- Development & Integration Manager -- 02074713462 ----- ------ Shazam Entertainment -- "If it sounds good, tag it!" (tm) ------- This e-mail and its contents are strictly private and confidential. It must not be disclosed, distributed or copied without our prior consent. If you have received this transmission in error, please notify Shazam Entertainment immediately on: 020 7471 3440 and then delete it from your system. Please note that the information contained herein shall additionally constitute Confidential Information for the purposes of any NDA between the recipient/s and Shazam Entertainment.
Kai Vehmanen | 2 Mar 20:11 2004
Picon
Picon

Re: Compiling under cygwin

On Tue, 2 Mar 2004, Ryan*PC Gibson wrote:

>     I am having problems compiling ecasound under cygwin.  I have 
> updated my cygwin/win2k installation with the latest version of 
> everything (gcc 3.3.1).  I have tried compiling ecasound-2.2.1, 
[...]
> ecasound.cpp: In function `void* ecasound_watchdog_thread(void*)':
> ecasound.cpp:489: error: `sigwait' undeclared (first use this function)
> ecasound.cpp:489: error: (Each undeclared identifier is reported only 

Cygwin doesn't provide sigwait() and Ecasound's configure should
detect this. I just testing compiling 2.3.2 and had no problems.
You could try the following work-around:

- run ./configure
- edit config.h by commenting out HAVE_SIGWAIT:
  /* #undef HAVE_SIGWAIT */
- re-run make

.. but, but, something still goes wrong in configure. Could
you send me (privately) the config.log file that is created
when you run configure?

--
 http://www.eca.cx
 Audio software for Linux!

--
To unsubscribe send message 'unsubscribe' in the body of the
message to <ecasound-list-request <at> wakkanet.fi>.

Scott Berry | 6 Mar 17:48 2004

still having problems with no sound with os drivers

Hi there list,

I am trying to record my keyboard from a line in to ecasound.  when I
perform the following command everything sets up right but I get no audio
at all.  The command I use is:

"ecasound -i:/dev/dsp0 -o test.wav."  When I play test.wav I get
absolutely nothing.  I don't hear anything and I am positive that I have
everything hooked up.  I am using the Os sound drivers on a Debian system
with a Sound Blaster sound card with the jacks in the back.  The keyboard
is plugged in to the second jack from the left as you are facing the front
of the computer.  I am desperately needing some help here as I have just
created a couple of songs and need to remove them from my kehyboards
memory.  If anyone can help me I would certainly appreciate it.

--
To unsubscribe send message 'unsubscribe' in the body of the
message to <ecasound-list-request <at> wakkanet.fi>.

didier.b | 6 Mar 19:23 2004
Picon

About encoding OGG in specific bitrates

Hi !

 

I want to compress from a MP3 to an OGG <at> 35000 Bps

 

ecasound -C -t:450 -b:2048 -a:1 -i:totaleclipse_thecrucible.mp3 -a:2 -i:djtaldjloop.mp3 -a:all -o:total_test1.ogg,35000

 

It seems that I can't encode with a bitrate less than 45000…

I get this error :

            Warning! An output object has raised an error! Out of disk space, permission denied, etc?

 

Any idea that can help me ?

 

WFX

 

Lance Hoffmeyer | 6 Mar 21:57 2004

alsa and ecasound2.2

Hello,

I am using a mixture of Stable/Unstable
with kernel 2.6.2 and ALSA support enabled.

Two soundcards SBLive and Delta M-66

The SBLive plays fine.  I can use Envy24control
and get sound from the Delta M-66. So, both
soundcards work with ALSA.

When I try to use ecasound2.2 I get the following error:

ecasound -i alsa,0,0 -o test.mp3

****************************************************************************
*               ecasound v2.0.3 (C) 1997-2001 Kai Vehmanen                 *
****************************************************************************
- [ Chainsetup/Enabling audio inputs ] -------------------------------------
ALSA lib pcm.c:1937:(snd_pcm_open_noupdate) Unknown PCM 1
---
ERROR: [ECA-CHAINSETUP] : "Enabling chainsetup: AUDIOIO-ALSA3: Unable to 
open ALSA--device for capture; error: No such file or directory"

buddha:~# ecasound -i alsa,0,0 -o test.wav
****************************************************************************
*               ecasound v2.0.3 (C) 1997-2001 Kai Vehmanen                 *
****************************************************************************
- [ Chainsetup/Enabling audio inputs ] -------------------------------------
ALSA lib pcm.c:1937:(snd_pcm_open_noupdate) Unknown PCM 0
---
ERROR: [ECA-CHAINSETUP] : "Enabling chainsetup: AUDIOIO-ALSA3: Unable to 
open ALSA--device for capture; error: No such file or directory"

Can someone help?

Lance

--
To unsubscribe send message 'unsubscribe' in the body of the
message to <ecasound-list-request <at> wakkanet.fi>.

Lance Hoffmeyer | 6 Mar 23:20 2004

Re: alsa and ecasound2.2 SOLVED

Not sure why, but this change in command 
fixed the problem.  Now I can record and
playback.

 ecasound -i alsa,default -o test.mp3

Lance

> 
> Hello,
> 
> I am using a mixture of Stable/Unstable
> with kernel 2.6.2 and ALSA support enabled.
> 
> Two soundcards SBLive and Delta M-66
> 
> The SBLive plays fine.  I can use Envy24control
> and get sound from the Delta M-66. So, both
> soundcards work with ALSA.
> 
> When I try to use ecasound2.2 I get the following error:
> 
> ecasound -i alsa,0,0 -o test.mp3
> 
> ****************************************************************************
> *               ecasound v2.0.3 (C) 1997-2001 Kai Vehmanen                 *
> ****************************************************************************
> - [ Chainsetup/Enabling audio inputs ] -------------------------------------
> ALSA lib pcm.c:1937:(snd_pcm_open_noupdate) Unknown PCM 1
> ---
> ERROR: [ECA-CHAINSETUP] : "Enabling chainsetup: AUDIOIO-ALSA3: Unable to 
> open ALSA--device for capture; error: No such file or directory"
> 
> buddha:~# ecasound -i alsa,0,0 -o test.wav
> ****************************************************************************
> *               ecasound v2.0.3 (C) 1997-2001 Kai Vehmanen                 *
> ****************************************************************************
> - [ Chainsetup/Enabling audio inputs ] -------------------------------------
> ALSA lib pcm.c:1937:(snd_pcm_open_noupdate) Unknown PCM 0
> ---
> ERROR: [ECA-CHAINSETUP] : "Enabling chainsetup: AUDIOIO-ALSA3: Unable to 
> open ALSA--device for capture; error: No such file or directory"
> 
> 
> Can someone help?
> 
> Lance
> 
> 
> --
> To unsubscribe send message 'unsubscribe' in the body of the
> message to <ecasound-list-request <at> wakkanet.fi>.
> 

--
To unsubscribe send message 'unsubscribe' in the body of the
message to <ecasound-list-request <at> wakkanet.fi>.


Gmane