Brian Cameron | 15 Mar 22:09 2006
Picon

Interest in working with Paranoia IV for Solaris


Hello, I would like to work on the CDParanoia IV code for Solaris.
I've looked at the xiph.org website and notice that the cdparanoia
code available in Subversion and the downloadable tarball does
not work on Solaris, so I'm guessing this is only CDParanoia III.

Would it be possible for me to also work on the CDParanoia IV code?
I am interested in trying to get it working with the Forte compiler
on Solaris.

Brian
Ruben Safir | 15 Mar 23:13 2006

Re: Interest in working with Paranoia IV for Solaris

I haven't seen anyone touch that code in a while and we found quite a
few weird coding snippets in it that don't make good use of allocated
memory.

Ruben
President NYLXS

On Wed, 2006-03-15 at 16:09, Brian Cameron wrote:
> Hello, I would like to work on the CDParanoia IV code for Solaris.
> I've looked at the xiph.org website and notice that the cdparanoia
> code available in Subversion and the downloadable tarball does
> not work on Solaris, so I'm guessing this is only CDParanoia III.
> 
> Would it be possible for me to also work on the CDParanoia IV code?
> I am interested in trying to get it working with the Forte compiler
> on Solaris.
> 
> Brian
> _______________________________________________
> Paranoia-dev mailing list
> Paranoia-dev <at> xiph.org
> http://lists.xiph.org/mailman/listinfo/paranoia-dev
R. Bernstein | 15 Mar 23:24 2006
Picon

Interest in working with Paranoia IV for Solaris

I believe the port of cdparanoia that comes with libcdio
(http://www.gnu.org/software/libcdio) works on Solaris. Or at least it
does for me.

A new release of libcdio is likely to happen soon and this will
contain some work by Peter Creath in commenting the paranoia code. So
best to use what's in CVS (or contact me for a candidate tarball).

Brian Cameron writes:
 > 
 > Hello, I would like to work on the CDParanoia IV code for Solaris.
 > I've looked at the xiph.org website and notice that the cdparanoia
 > code available in Subversion and the downloadable tarball does
 > not work on Solaris, so I'm guessing this is only CDParanoia III.
 > 
 > Would it be possible for me to also work on the CDParanoia IV code?
 > I am interested in trying to get it working with the Forte compiler
 > on Solaris.
 > 
 > Brian
 > _______________________________________________
 > Paranoia-dev mailing list
 > Paranoia-dev <at> xiph.org
 > http://lists.xiph.org/mailman/listinfo/paranoia-dev
 > 

Gmane